Find the answer to your Linux question:
Results 1 to 8 of 8
Hi everone. I bought a tvtuner card the other day. It works fine in WindowsXP, but I cant get it to work in Mandrake 10. I want to move away ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    Trouble with FUNTV / TUN900 tv tuner


    Hi everone.

    I bought a tvtuner card the other day. It works fine in WindowsXP, but I cant get it to work in Mandrake 10. I want to move away from XP and become a Linux user.

    I have read forums, howto's, websites, you name it. I just cant get it to work. I hear noises (like it is off channel) when I run any Tv software(tvtime, xawtv,etc.), but I cant get it to show a picture. I think it has something to do with the tuner, but I have tried all the tuner and card types that are available.

    My card details (from website):

    FUNTV / TUN900

    Most Advanced Philips Silicon Tuner/Video Decoder
    Worldwide TV standards (NTSC, PAL, and SECAM)
    Multiple tuner receptions (B, G, H, D, K, I, M, N, L, and L’)
    Stereo TV/SAP sounds-MTS (BTSC, EIAJ, A2 or NICAM)
    Personal Video Recorder
    FM Radio reception – (optional)
    Infrared Remote Control – (optional)

    --------------------------------------------------------------------------------


    Stereo TV Tuner Card with FM Radio
    PCI TV tuner and capture board
    High quality TV tuner for hyper band cable and terrestrial antenna reception Supports all analogue TV standards in the world (NTSC, PAL, and SECAM), and tuner systems (B, G, H, D, K, I, M, N, L, and L’), no need to change tuner from one region to another
    Stereo FM radio reception (Optional)
    Stereo TV/SAP sounds-MTS (BTSC, EIAJ, A2 or NICAM)
    Full function infrared remote control
    Supports MPEG1, MPEG2, VCD, SVCD, and DVD capture format
    Digital video recording, directly capture from video source (such as TV, VCR, DVD, Camcorder, etc.) to MPEG1 and MPEG2 files
    16-Channel preview, thumbnail video to display all of currently broadcasted programs on available channel
    Supports De-Interlacing to get high quality of motion video
    Provides daily/weekly reservation-recording schedule
    Time-shifting playback, simultaneously watch and record the TV program with immediate replay and pause
    Bundle with CyberLink® Power VCRII™ Software

    http://www.yuan.com.tw/en/products/vdo_tun900.html

    Is there anyone that can help?

    Please
    John

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    http://www.mandrakelinux.com/en/errata.php3#draktv

    There's a bug in draketv. Go to the link above to read about it. I've tried the patch but it only worked half-assed.
    OH NOOOOO!!!!!! You did it the way I said?

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    Tried that

    Hi.

    I tried that as well. Dont know if Ill be watching TV in Linux anymore.

    Im stuck....

    If anyone can help, please reply.



  4. #4
    Just Joined!
    Join Date
    Oct 2005
    Location
    Japan
    Posts
    3

    better way

    http://linux.softpedia.com/progDownl...load-1960.html
    (this site might help you)

    http://ring.aist.go.jp/archives/linu...-saa7135.patch
    (this patch is already included in kernel-2.6.14-rc3)

    kernel-2.6.14-rc3 supports saa7135.

    so the better way I think is to build new kernel-2.6.14-rc3 by yourself and restart with this kernel.

    to build the new kernel takes time but is very useful.

    drivers/media/video/saa7134/
    saa7134-cards.c
    saa7134.h

    Thanks.

  5. #5
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I tried to get a Hauppage tv tuner to work in Mandriva, but never managed it... Support for tv cards isn't very good.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Any bttv tuner should work fine on Linux. I've been using it for months now.

    Unfortunately, google returns next to nothing on getting your card working under linux. Not a good sign. However, my TV Tuner was like $30, it works with Linux and I can even control with the remote control.

    Good luck!
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  7. #7
    Just Joined!
    Join Date
    Oct 2005
    Location
    Japan
    Posts
    3

    One step forward!

    http://www.icewalkers.com/Linux/Soft...ernel-2.6.html

    I downloaded 2.6.14-rc5 kernel source codes from above site.
    My distro is Fedora Core 4.
    So I built new kernel.
    http://www.atmarkit.co.jp/flinux/ren...rnelrbfc2.html
    I build 2.6.14-rc5 kernel as same way as above site.(This is in Japanese)

    Then I reboot and choose my new kernel from GRUB menu.
    Type
    # rmmod saa7134
    # modprobe saa7134 card=66
    # dmesg
    Then ....

    saa7130/34: v4l2 driver version 0.2.14 loaded
    PCI: Found IRQ 10 for device 0000:00:0f.0
    PCI: Sharing IRQ 10 with 0000:00:0d.0
    saa7133[0]: quirk: PCIPCI_NATOMA
    saa7133[0]: found at 0000:00:0f.0, rev: 240, irq: 10, latency: 64, mmio: 0xf4004000
    saa7133[0]: subsystem: 12ab:0800, board: Yuan TUN-900 (saa7135) [card=66,insmod option]
    saa7133[0]: board init: gpio is 0
    saa7133[0]: dsp access wait timeout [bit=WRR]
    saa7133[0]: dsp access wait timeout [bit=WRR]
    saa7133[0]: dsp access wait timeout [bit=WRR]
    tuner 1-004b: chip found @ 0x96 (saa7133[0])
    tuner 1-004b: tuner: type set to tda8290+75
    saa7133[0]: i2c eeprom 00: ab 12 00 08 00 00 00 00 00 00 00 00 00 00 00 00
    saa7133[0]: i2c eeprom 10: ff ff ff ff 15 00 05 01 13 c2 db ff ff ff ff ff
    saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    saa7133[0]: registered device video0 [v4l2]
    saa7133[0]: registered device vbi0
    saa7133[0]: registered device radio0
    Debug: sleeping function called from invalid context at include/asm/semaphore.h:102
    in_atomic():0, irqs_disabled():1
    [<d095cd02>] i2c_clients_command+0x22/0xf0 [i2c_core]
    [<d0ad3a65>] video_do_ioctl+0xcd5/0xf20 [saa7134]
    [<c0335c1f>] unix_stream_sendmsg+0x2ef/0x3e0
    [<c01c4ffa>] avc_has_perm+0x5a/0x70
    [<d098c32b>] video_usercopy+0x6b/0x180 [videodev]
    [<c01c889f>] selinux_file_ioctl+0xef/0x380
    [<d0ad3cc9>] video_ioctl+0x19/0x20 [saa7134]
    [<d0ad2d90>] video_do_ioctl+0x0/0xf20 [saa7134]
    [<d0ad3cb0>] video_ioctl+0x0/0x20 [saa7134]
    [<c0174059>] do_ioctl+0x69/0x70
    [<c017419c>] vfs_ioctl+0x5c/0x1f0
    [<c01743a2>] sys_ioctl+0x72/0x90
    [<c01030bb>] sysenter_past_esp+0x54/0x75

    My handmade kernel detected Yuan TUN-900 !!
    One step Forward!!

    Then I tried "tvtime" and "xawtv", but no video and sound appeaerd. Very sorry.
    Anyway, I continue to try more until my challenge will get successful.

  8. #8
    Just Joined!
    Join Date
    Oct 2005
    Location
    Japan
    Posts
    3

    I did it!! Success !!

    I live in Japan, so my stations are NTSC_JP & japan-broadcast.

    Type

    # tvtime -f japan-broadcast -S

    then

    Video processing ->
    Input filters ->
    Color inverts'check should be cleared and
    Mirror's check should be cleared.

    If I want to see Channel 4 (In Japan, "Nihon-TV"),
    type 4 and enter on the tvtime screen.

    If "No signal" is displayed on the blue screen,
    click left of the mouse and display the menu.

    Channel management -> Current Channel active in list

    Then check "Current Channel active in list".
    Then click "Finetune current channel".
    Then default value may be 0, so click "decrease" to "-10".
    Suddenly the TV programs shows up on the screen and then
    adjust with decrease/increase.

    Like this way, I succeeded to watch almost all stations in Tokyo area.
    I did it.

    P.S. My PC is Sony VAIO(Used PC)/ Pentium 2 - 400MHz / DRAM 256MB / HDD120GB.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •