Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I've installed VLC and also gone to the Easy Urpmi to install whatever it is that site installs (I think codec?). Basically when I use VLC I get sound but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    13

    VLC with sound but no video


    I've installed VLC and also gone to the Easy Urpmi to install whatever it is that site installs (I think codec?). Basically when I use VLC I get sound but no picture, it just shows up green???

    Any help would be greatly appreciated, thanks in advance!

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    su -
    lspci | grep -i vga
    grep -i driver /etc/X11/xorg.conf
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    13
    Quote Originally Posted by devils_casper View Post
    Execute this
    Code:
    su -
    lspci | grep -i vga
    grep -i driver /etc/X11/xorg.conf
    Post output here.
    lspci | grep -i vga
    01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 01)

    grep -i driver /etc/X11/xorg.conf
    Driver "kbd"
    Driver "mouse"
    Driver "via"

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You have configured X Server correctly.

    Open VLC Player, Go to Preferences -- Video -- highlight Output Modules.
    Check Advanced Options at the bottom and select X11 video output from the drop-down list.

    Restart VLC Player.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    13
    Quote Originally Posted by devils_casper View Post
    You have configured X Server correctly.

    Open VLC Player, Go to Preferences -- Video -- highlight Output Modules.
    Check Advanced Options at the bottom and select X11 video output from the drop-down list.

    Restart VLC Player.
    I love you

  7. #6
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4
    Hi i tried the above and got this as an outout

    lspci | grep -i vga
    00:02.0 VGA compatible controller: Intel 945GME Express Integrated Graphics Controller (rev 03)
    grep -i driver /etc/X11/xorg.conf
    Driver "kbd"
    Driver "synaptics"
    Driver "mouse"
    Driver "intel"

    I tried the x11 video output and all the others on the list
    Any help would be greatly appreciated thanks

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Try Driver "vesa" instead of "intel" in /etc/X11/xorg.conf file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4
    Hi thanks

    From a terminal window?
    I get error permision denied even after i type in my root password :s

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    sudo nano /etc/X11/xorg.conf
    Edit file and press Ctrl+X, Y and hit Enter key to save file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4
    Sorry to keep bugging you but when i enter that im getting

    bash: nano: command not found

    Im running Linpus Lite on the Acer Aspire one if that helps
    Thanks

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •