Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I've created udev rules that assign specific names for my usbkeys but they have stopped automounting... my fstab lines are: /dev/usbkey1 /mnt/kingstette1 vfat defaults 0 0 /dev/usbkey2 /mnt/kingstette2 ext3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    7

    Reactivating automount of usbkeys


    Hi,

    I've created udev rules that assign specific names for my usbkeys but they have stopped automounting...

    my fstab lines are:
    /dev/usbkey1 /mnt/kingstette1 vfat defaults 0 0
    /dev/usbkey2 /mnt/kingstette2 ext3 defaults 0 0

    Can anyone suggest how to reactivate the automount?

    thanks!

    Oh & if someone can remind me the flags to give "rw" in vfat to all users, I'd appreciate.

    Thanks!

  2. #2
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    557
    What are you doing for God's sake?!
    You don't have to change anything in your fstab! USB drives have nothing to do with the fstab. Please remove your changes. If you're lucky, you'll find the backup copy of the original fstab file in your /etc folder. Use that one!
    Actually, what is your exact problem with USB-keys?
    When you first time plug in a USB key you're questioned how to handle that device, and you can tell the system to automatically open that device in Konqueror (=automount). If you missed that, you can make this step in Control Center at the Peripherals.
    Don't be so quick, better ask before you do something, otherwise you'll have to reinstall your system very soon!
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  3. #3
    Just Joined!
    Join Date
    Mar 2008
    Posts
    7
    hi,

    thanks for the lesson hehe

    My actual problem was in two folds:

    1) I had two partitions on my USB key: on vfat & one ext3. I wanted both to be mounted automatically... AND to have rw access for all users. The ext3 was no problem but the vfat was....

    2) They were assigned varying device names each time & mounting in varying places! Can't recall the exact details but I wanted something clean: ie partition1 mount on /dev/usbkey1 (through udev) & I can always mount /dev/usbkey1 to /mnt/key1

    I have looked but so far, I cannot find where to retrace those steps you're mentionning in control center...
    If you can clarify (its also coz mine is in french

    Cheers mate

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    557
    That's a good question!
    The problem with fstab is that there are listed only the static devices and CD/DVD drives. Here's my fstab:
    # Entry for /dev/hda5 :
    UUID=e0d0f499-e6f6-4207-93dc-dbaa11791d93 / ext3 relatime 1 1
    /dev/cdrom /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
    /dev/cdrom2 /media/cdrom2 auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
    # Entry for /dev/hda7 :
    UUID=47D1-3A3D /mnt/fat32 vfat iocharset=utf8 0 0
    # Entry for /dev/hda1 :
    UUID=2AA8579AA857637D /mnt/windows ntfs-3g defaults,umask=0 0 0
    none /proc proc defaults 0 0
    # Entry for /dev/hda6 :
    UUID=5c8d2cbf-b9e1-44ba-82ac-2f0003ed1884 swap swap defaults 0 0

    Eventually you could try to put two lines into your fstab:
    /dev/sda1 /media/usb1 vfat defaults, umask=0 0 0
    /dev/sda2 /media/usb2 ext3 defaults, umask=0 0 0

    I don't know if this would help you. I actually never worked with more than 1 partition on USB, but if it could work, it will with these lines.
    Or, maybe you could put "auto" instead of vfat and ext3?
    I'll try to do the same.
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  6. #5
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    557

    Smile A solution

    This is what I've done using my 256MB USB key:
    1. Format the USB key and create as many partitions as you want to. I've used your pattern and created 1 ext3 partition and 1 vfat partition.
    2. Probably you've already canceled the USB automonting with KDE, so you'll have to reuse it. Try to find the KDE Control Panel (or Center?). Under "Peripherals" (find the equivalent in French for that word) and Select the "Storage Devices" submenu.
    At the top of the right side of the panels you'll find a combobox with different kinds of devices, CD-ROMs, DVDs, Video CDs...Select the "Unmounted storage device" or similar. After that select the "Open in new window" option and push Apply.
    3. Normally, next time you plug in your key the partitions shall be automounted and opened in separated windows.
    4. I had a small problem with one of the partitons: I had to change the access mode with: # chmod -R 777 /media/disk
    The partitions shall be mounted as /media/disk and /media/disk1
    I hope you'll manage to repeat my steps!
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  7. #6
    Just Joined! Xheralt's Avatar
    Join Date
    May 2006
    Location
    Milwaukee, WI
    Posts
    28

    Related question(s)

    Hi, I'm fairly new to linux, I've been using it for a little over a year now, but certain things still elude me. My situation is that I've volunteered my help for a startup coffeehouse maintaining their public internet-access computers, and gradually been converting them from Win2k to PCLinuxOS. I've kept one machine in particular to dual-boot, just in case a customer decides to be absolutely allergic to Linux. These are full-desktop acess machines, not kiosk-mode.

    Now, the problem is, I want to keep the Windows partition restricted to root-access only from within Linux, so I set permissions on the fstab-defined mountpoint accordingly, but I seem to have mucked up all mounting -- root access is now required for mounting USB keys, which I *don't* want, people should be able to access their own personal storage without expert intervention. I'm also worried that someone with more Linux finesse than I will *still* be able to acquire (effectively) root access to the Win2k partitions. Can this be done with an open desktop, or do I have to go kiosk mode?

  8. #7
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Quote Originally Posted by Xheralt View Post
    Now, the problem is, I want to keep the Windows partition restricted to root-access only from within Linux, so I set permissions on the fstab-defined mountpoint accordingly, but I seem to have mucked up all mounting -- root access is now required for mounting USB keys, which I *don't* want, people should be able to access their own personal storage without expert intervention. I'm also worried that someone with more Linux finesse than I will *still* be able to acquire (effectively) root access to the Win2k partitions. Can this be done with an open desktop, or do I have to go kiosk mode?
    You would probably be better starting a new thread for this ... if you want help with the mounting issue I suggest you post /etc/fstab contents
    Code:
    cat /etc/fstab
    and also post output of
    Code:
    fdisk -l
    You will need root access rights for the fdisk command, and the l is a small L.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •