Find the answer to your Linux question:
Results 1 to 10 of 10
OK, I'm a complete newbie when it comes to Linux, so this post may give some of you a good laugh, but please bear with me. I have all three ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11

    10 won't install from CD


    OK, I'm a complete newbie when it comes to Linux, so this post may give some of you a good laugh, but please bear with me.
    I have all three ISO's downloaded and on CDs for Mandrake Community 10. If I am already booted into either Move 9.2 (which I am using right now) or Windows XP, inserting the first installation disc into the CD drive pops up an installation window with a link to "Install Mandrakelinux." When I click on that link, a dialogue box pops up saying the machine will be rebooted and Mandrakelinux will be installed.
    Great! That's exactly what I want to do! So I click OK. The machine restarts, but then boots back into Windows, not even acknowledging that Linux was supposed to install.
    Correct me if I'm wrong, but aren't the Mandrake CDs supposed to be bootable? I'll clarify before you ask: yes, the CD is before the HD in the boot sequence.
    Am I doing something incorrectly? Have I provided enough information? Anyone else ever had this problem?

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    UPDATE
    ==============
    Weird. For kicks, I inserted the second CD and rebooted to see what would happen. It booted and started the installation wizard, then, when it realized the installation CD wasn't in the CD drive, it asked for the installation CD, the first CD, from which I had first tried to boot. We'll see how it likes my Winows XP installation... I'll post another update when it has finished installing so everybody knows how it turned out.
    Anyone have any ideas as to why the first disc is not bootable?

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    UPDATE
    ==============
    OK, back again. I think I finished installation. It asked for a fourth installation disc. Aren't there only 3? Is the fourth for the purchased version that includes commercial, non-open-source software?
    Anyway, now when I reboot, I get this error message: "LILO - Keytable read/checksum error." This is where everything stops. It does not boot into Linux. What does that mean? And what do I do to fix it? I know there is some mysterious file somewhere called lilo.conf, and that it contains instructions for Linux on how to boot the computer among other things, but I do not even know where it is, much less what to change to get this error to go away and to get Mandrake to boot.
    Another issue I think I will have to address is how to get Windows and Linux to play nicely with each other and not fight over MBR and simply resolve to letting me choose which of them to use. However, for now, I just want to get Linux operable.

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    There was a problem with 10 Community with the disks booting. It's fixed n the official release, 10.0. You should get all four of those and install instead, there were many updates.

    Perhaps that will fix your lilo error as well.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    Thanks for the reply, Jeremy. I thought I had the official release. Do you know a good site--FTP, HTTP, or otherwise--from which I might download the ISOs? It took quite a while to find the ISOs for Community, and I thought I had finally found what I needed. I just didn't want to scroll through thousands of RPMs to select only a few that I may or may not need to complete the installation of Mandrake 10 on my machine.
    If you do not have a recommendation for the ISOs, could you point me in right direction for downloading the right files? While intriguing and undoubtedly a valuable resource, it was quite overwhelming to find a list of over 3 Gb of RPMs available at most every FTP mirror for Mandrake 10. How do most people download Linux and all the correct RPMs and all the other files necessary to complete an installation? Is it simply by using the setup wizard and choosing the RPMs from the Update section of the installation? Some guidance here would be great!!! Thanks again!

  6. #6
    Just Joined!
    Join Date
    Aug 2004
    Posts
    9
    Am I understanding this thread correctly, that there is an issue w/ bootable CD's for Mandrake 10?

    OK, at work on the 20 MB connection I reeled in the 3 Mandrake 10 CD's from a great mirror (300K/sec connection average!). Burned them all, made SURE I checked the option to make CD#1 bootable (Roxio EasyCD 5), but altho BOIS says look to the CDROM on boot, it don't boot.....

    I'm looking to over-write/fresh install on a working RH 9 box, the one i'm actually working on right now....

    jeez.....I can't even find rawrite on disk 1 or 2; haven't looked at 3....

    CDRom is Plextor R/W; 40/12/40A; I *seem* to recall I saw it was doing SCSI emulation on boot, if I am reading the boot process right and if that makes a difference....PII 266/400 MB ram...nothing too fancy.... (as it scrolls by at boot...)..it is secondary master.

    I see bootcat.bin and bootimg.bin on that CD#1 (from within X, so I KNOW the CD's at least reading...); is there some concept that's eluding me?

    Is THIS the problem that is being hashed out here??

    Heck, i'll go BUY the distro at the local megastore if anyone thinks that'll do it...what actually BOOTS out there? Tried the #2 disk as well, but didn't burn THAT one to boot...just #1...

    Looking for a bit of direction...thanks!!

    regards,
    vinylone

  7. #7
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    UPDATE
    ==============
    Ditched trying to install 10 Community and downloaded 10 Official. Boot process went well, started installation normally. However, I still have not gotten LILO to work, and I don't know what I am doing wrong. If anyone has any ideas, please post here.
    In LILO's stead I am using Grub, and it seems to work just fine. When I reboot though, there are 6 or 7 items in the Grub boot menu; is that normal?
    Also, can anyone explain to me the advantages and disadvantages of using LILO and Grub? I am a little confused as to why there are two boot managers, and which I should use.

  8. #8
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    there are errors with community, simply put, download the offical ISO's and just use those.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  9. #9
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    Quote Originally Posted by vinylone
    ...I reeled in the 3 Mandrake 10 CD's from a great mirror (300K/sec connection average!)...
    Dang, vinylone, 300K/sec? That's quick. Mind sharing the address of the mirror?

  10. #10
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2

    Mandrake 10 is great

    So far I haven't got any problem with it, as to my understanding lilo is the default boot loader in Mandrake...the configuration file is located under /etc/lilo.conf
    you can edit this file with vi editor

    for each:

    image=/boot/vmlinuz
    label="*****"
    root=/dev/hdax
    initrd=/boot/initrd.img
    append="devf=mount acpi=ht resume=/dev/hda6 ******"
    ******
    ******


    Is an item on your list on the boot menu

    you can remove those you don't need or add as necessary.

    or to reinstall the boot loader, reboot with CD1 and at the first welcome screen type rescue and hit enter.

    this will drop you to a troubleshoting menus and you will find an option that says reinstall the boot loader. By doing this will automatically ad all OSes currently installed on your system.

    If you want to learn Mandrake well....You should read Agustin's Linux Manual, The first edition is free and available at many places or you can get the second edition at http://www.netcontrol.org

    This is the very best documentation out there...and I do recommend it to all newbies to experst as well.

    Anyway I hope this will help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •