Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 33
No don't uninstall just yet ... try your favourite command ! Code: su - then Code: parted you should be able set the boot flag on the first partition. At ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,049

    No don't uninstall just yet ... try your favourite command !
    Code:
    su -
    then
    Code:
    parted
    you should be able set the boot flag on the first partition.
    At the parted prompt type set, then when prompted for partition number type 1, then b for boot flag, then enter default should turn the boot flag on, then quit.
    If you run
    Code:
    fdisk -l
    again you should see the * by the first partition.
    After that try shutdown and reboot system and see if Windows will start.

  2. #22
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    362
    title windows
    root (hd0,0)
    Your XP is on an NTFS partition so root will not work. Root tells grub to mount the system, but it does not know how. rootnoverify must be used.

    Try:
    title windows XP
    rootnoverify (hd0,0)
    makeactive
    chainloader+1

  3. #23
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    ok thanks guys i will go try that and report back.

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    hi, for some reason when i type su - and then my password, when i type parted, it says unknown command?

  6. #25
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,049
    Quote Originally Posted by Barry Thomas-Brown View Post
    hi, for some reason when i type su - and then my password, when i type parted, it says unknown command?
    You can achieve the same thing with fdisk ... start it with fdisk /dev/hda. m should bring up help ... a is used to toggle the boot flag.

  7. #26
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    ok, did that, its set to first partition, i can see its set against the ntfs and not extended, extended is now second in the list. changed the menu.lst to rootnoverify, but still noooooo joy, lol.

    i noticed that when i was going through fdisk, it said something about me having too many cylinders? and that this can affect the booting of other OS. not sure if that sheds any light.
    Last edited by Barry Thomas-Brown; 03-22-2008 at 05:23 PM. Reason: spelling :)

  8. #27
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,049
    Do you have a live CD with gparted on?
    Do you have a Windows install CD?

  9. #28
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    I've got Mandriva One CD yeah, and also widnows xp install cd. i was thinking of deleteing the Mandriva partitions using the windows xp cd and booting up back into windows and give mandriva another go, what u think?

    not sure about gparted, what that means

  10. #29
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,049
    My suggested approach below obviously won't be a five minute job ... anyone else have any comments on this approach or a better way to fix the issue?

    I suggest you backup user data then try to fix windows. Try fixmbr first and see if you can get windows to boot. There are two CDs I would get hold of ... SuperGrub and PartedMagic. Supergrub will help you fix boot issues in future and PartedMagic will let you resize partitions.

    I'd move XP back to the beginning of the hard drive. You can achieve this with PartedMagic or by doing a fresh Windows install - use the start of the disk for the Windows install.

    Then make your extended partition after the Windows partition and install Linux in the extended partition.

  11. #30
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    ok gonna try the mbr thing first then. thanks for your help jonathan u been a great help and all u other guys too. i will post back once i tried everything out

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •