Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 33
I managed to install Mandriva One nice and easily enough last night. However I am stuck on how to set up dual booting. I have Windows XP on one partition ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22

    Dual Booting need help


    I managed to install Mandriva One nice and easily enough last night. However I am stuck on how to set up dual booting. I have Windows XP on one partition with M1 on the other. On start up i am presented with the options to boot with either linux or windows. when i attempt to boot up using windows i get:

    root (hd0,0)
    filesysyem type unknown
    partition type ox7
    make active
    chainloader +1
    _

    that last flashing dash just stays flashing and nothing happens. I think i probably need to configure something somewhere in GRUB? However when i try accessing menu.lst i can edit but wont allow me to save. I have no idea what to change it to anyway

    can anyone guide me through setting this up? I am a complete linux noob, only using it for the last mmmm 10hours or so

    I am using the GRUB menu on start up if that helps. thanks!!!!!!

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You must have root privileges to edit menu.lst file.
    Execute this
    Code:
    su -
    nano /boot/grub/menu.lst
    Press Ctrl+X, Y and hit Enter key to save file.

    In case you couldn't setup dual boot, post the output of this
    Code:
    su -
    fdisk -l
    * Its small L in fdisk -l. That command will list partition structure only. Just post output of it here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    thanks for responding so quickly i will do this now and get back to you

  4. #4
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    ok, not sure what i was doing wrong in first command but it wasnt working for me, so i have posted the second command results below for u, thanks!!!!

    Disk/dev/hda: 163.9 GB
    255 heads, 63 sectors/track 19929 cylinders
    units=cylinders of 16865 * 512=8225288 bytes
    Disk identifier = ox86828682

    Device Boot Start End Blocks ID System
    /dev/hda1 7649 19928 98639868+ 7 HPFS/NFTS
    /dev/hda2 1 7648 61432528 5 Extension
    /dev/hda5 1 1819 8185854+ 83 Linux
    /dev/hda6 1828 1528 4888511 82 Linux Swap/solaris
    /dev/hda7 1529 7648 49158868+ 83 Linux

    partition table entries are not in disk order


    hope this helps!! thanks for your help appreciated.

  5. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,105
    If nano doesn't work, try (in terminal) as devils_caspar suggested: su -, enter your password, then type: 'kwrite /boot/grub/menu.lst' without the '. Post it.

  6. #6
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    thanks yancek, i will try that and post results, just to make sure, is terminal the command console found in the configure your computer section? thanks.
    Last edited by Barry Thomas-Brown; 03-21-2008 at 10:25 PM. Reason: mispelt name

  7. #7
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    ok, that command worked, however still have same issue. it opened the file, i can edit it but when i go to save it says; 'unable to save, check that you have write access to this file.'

    thanks for your help on this guys.

  8. #8
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,105
    konsole/terminal are terms used interchangeably. On Mandriva, click the Menu in the lower left of your taskbar, slide mouse arrow up to tool, hold there and on the right you will see another menu come up which includes 'konsole'. Click on that.

  9. #9
    Just Joined!
    Join Date
    Mar 2008
    Posts
    22
    ah ok cool, did that but still the same any ideas?

  10. #10
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    Quote Originally Posted by Barry Thomas-Brown View Post
    ah ok cool, did that but still the same any ideas?
    Can you post the output of
    Code:
    su -
    cat /boot/grub/menu.lst

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •