Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I can't for the life of me figure out how to change the keyboard setting in GNOME 2.4 to fix this problem I'm having: When it comes to my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    Adelaide, Australia
    Posts
    4

    GNOME keyboard quotation marks and apostrophe


    Hi,

    I can't for the life of me figure out how to change the keyboard setting in GNOME 2.4 to fix this problem I'm having:

    When it comes to my quotation mark " and apostrophe key ', you know, the one next to the enter key.... currently when I press it nothing happens. If I press it twice in succession, I get the symbol, or the symbol if I hold shift. To get standard apostrophe ' and quotes ", I have to press the quote/apostrophe key and hit space.

    And it is REALLY IRRITATING! I've tried to search for more information, but I haven't had much luck because I have no clue what to search for.

    It didn't do this in Mandrake 9.2 (which had an earlier version of GNOME).

    Any hints much aprechiated,

  2. #2
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    One good idea would be to make sure the "InputDevice", "Generic Keyboard" section of your /etc/X11/XF86Config-4 file, or whatever section holds the information about your keyboard, contains the right information about your keyboard. That is, if you have a pc104 model, make sure you have a line that says
    Code:
    Option         "XkbModel"        "pc104"
    Good luck.
    Situations arise because of the weather,
    And no kinds of love are better than others.

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Location
    Adelaide, Australia
    Posts
    4
    I'll give that a try, thanks.

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Location
    Adelaide, Australia
    Posts
    4
    Nope, no such luck.

    It was set to pc105, so I changed it to pc104, but it hasn't rectified the problem.

    (my keyboard does only have 104 keys...)

  5. #5
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Although the thread below doesn't solve your problem, it does talk about it, maybe it will help:

    Thread

    I don't want to use dead keys where you have to hit the apostrophe twice (or apostrophe-space) to get an apostrophe.

    From reading the thread, it sounds you may have something wrong with your ~./Xmodmap file. Can you make accented e's real easy?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  6. #6
    Just Joined!
    Join Date
    Aug 2004
    Location
    Adelaide, Australia
    Posts
    4
    ćń mk ććńtd vŕthńg ŕĺl ś....

    :P

    Just by hitting the apostrophe key once followed by the letter.

    *goes off to read the thread*

    Thanks,

  7. #7
    Just Joined!
    Join Date
    May 2005
    Location
    United Knigdom
    Posts
    1

    Keyboard settings

    I recently installed Mandrake 10.1 on an Acer 202T, which previously had 9.1 installed. Ever since then, I have had to press the quote key then space to get the quote to show. The weird thing is, I used to have this problem with Windows ME, which was the original OS on the laptop.

    Today I fixed the problem, by simply changing the keyboard setting in the Mandrake "configure your computer" system. I changed it from "US Keyboard(International)" to "US Keyboard", and now all works well.

    Hope this helps someone else...

  8. #8
    Just Joined!
    Join Date
    Jul 2006
    Posts
    6

    Change to "US keyboard"

    Can confirm that changing the keyboard type to "US keyboard" fixes this problem, had this occur in Mandriva 2007 Free. Very annoying.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •