Find the answer to your Linux question:
Results 1 to 7 of 7
I've read that the best way to set up a dual-boot system--WinXP and MDK 10, in this case--is to allow NTLDR to control the MBR and inserting the boot record ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11

    LILO ate my computer


    I've read that the best way to set up a dual-boot system--WinXP and MDK 10, in this case--is to allow NTLDR to control the MBR and inserting the boot record into boot.ini to get NTLDR to recognize a Linux installation. So that's what I want to do.
    However, I have already attempted to install MDK 10 Community, and it has messed up my computer (someone told me it had lots of bugs and that I should download the official release). LILO took over the MBR from NTLDR. Now, when I try to boot the computer, it gives me this error: "LILO - Keytable read/checksum error."
    All I want to do now is give the MBR control back to NTLDR. I've inserted a bootable version of the WinXP installation CD, but it does not boot. I even took the HDD completely out of the boot sequence, so that I could eliminate drive structure from being the cause of the problem. The only boot item is the CD. However, nothing except Linux CDs will boot. I've tried both WinXP and 98, but it skips over the "Boot from CD :" prompt (leaves it blank), and displays the same error: "LILO - Keytable read/checksum error."
    All I want to do is put Windows back on the machine, but the bootable installation discs are not booting. What should I do to restore the MBR to NRLDR?
    Oh, one last thing--I don't have a floppy drive, so boot floppies will not work (unless of course I put the HD in another machine).

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Try booting Knoppix from CD. Once it starts, you can mount the HD and see what the problem is with Lilo. Post the lilo.conf file here.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    MN USA
    Posts
    70
    Do you have a burned win xp cd or the retail cd? If it's the retail CD, it should boot and let you get to the recovery console to fix your MBR (with command fixmbr and/or fixboot). Then you just have to reinstall LILO onto the linux partition.

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    Sorry it took so long to get back to posting here. Hectic weekend involved downloading the Official version MDK 10 (I was using Community) and installing it about 10 times trying to get it to work.
    Instead of using LILO, I tried Grub, and it seems to be working. Is LILO better? Should I use it instead of Grub? does one work better with Windows than the other?
    I have another open thread that may coincide with this problem.
    Jeremy, in response to your suggestion about posting my lilo.conf file here: I can't. I've run into another error, and it may be that it should be a separate thread.
    KDE will not start up in this installation of MDK 10. At the login window, KDE is selected by default, but will not load after I enter my password and press Enter. Instead I get error window titled, "DCOP communications error (Konqueror)," the screen goes blank, then it shows the login screen again. The full text of the error message is below.
    DCOP communication error (Konqueror)
    There was an error setting up inter-process communications for KDE. The message returned by the system was:

    Could not read network connection list.
    /home/jon/.DCOPserver_localhost__0

    Please check that the "dcopserver" program is running!
    [OK button]
    So I get that error and am sent back to the login screen. I then tried using IceWM and it worked. Now, here's a complete noob question: how do you open a new file browser window in IceWM? I can't figure out how to browse the directories on my computer. Talk about feeling helpless.
    I was trying to get to the /etc/ dir to grab my lilo.conf file to post here, but I can't figure out a way to browse it using the GUI.
    So instead, I tried the console. At the prompt I typed, "sudo /etc/lilo.conf," (without sudo it gives an 'insufficient privileges' error). Another noob question: Is this the correct command to open the lilo.conf file, or should I use something else?
    Anyway, when I type that command, I get the message, "Broken pipe" in the console, then get a new prompt line. Grrr...
    What is emacs? I opened it and tried to use it to open lilo.conf. It looks like it does it, but the window is empty. Grrr, again. Exiting gives a bunch of stuff about saving buffers and changing buffers and other buffer stuff, whatever that means.
    Then I tried good old Konqueror. Nothing. "Protocol not supported, 'file'" when I type /etc/lilo.conf into the address bar. I also tried just /etc/ to open the directory. Same thing.
    I either get the DCOP error or nothing happens when I try to open pretty much anything with a K in front of it. KWrite, Kopete, Kmail, Kontact, Knode, any of them. Don't know what that means.
    What is the DCOP server? What does it do? Why is it messing up KDE? What do I do to fix it?

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    Quote Originally Posted by systempilot
    Do you have a burned win xp cd or the retail cd? If it's the retail CD, it should boot and let you get to the recovery console to fix your MBR (with command fixmbr and/or fixboot). Then you just have to reinstall LILO onto the linux partition.
    It's a burned network XP install CD, not retail. However, I modified it to be bootable, and it has booted on every machine I've tried it on, even the one I'm having all this trouble with. It's just not now... I know it should boot.

  6. #6
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    Well, I still wasn't able to get LILO working, but GRUB is working, so I'm not gonna worry about it. KDE works now, too, after 3 or 4 more reinstalls. Don't know what I was doing incorrectly.
    New question: How do I configure GRUB to boot Windows? Please post actual code that would go into grub.conf; remember, I'm a newbie.
    Thanks, everyone, for all your help.

  7. #7
    Just Joined!
    Join Date
    Jul 2004
    Location
    MN USA
    Posts
    70
    1. Perhaps your WinXP CD is corrupt?

    2. You should be able to add something like this to the end of your grub.conf:
    Code:
    title Windows_XP
    rootnoverify (hd0,0)
    chainloader +1
    Change the (hd0,0) to reflect the physical location on windows XP (In the case above, it's located on teh first partition of the primary hdd).
    My grub.conf is setup for Fedora Core 2, but, just in case it helps, my complete grub.conf looks like:
    Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE:  You have a /boot partition.  This means that
    #          all kernel and initrd paths are relative to /boot/, eg.
    #          root (hd0,2)
    #          kernel /vmlinuz-version ro root=/dev/hde6
    #          initrd /initrd-version.img
    #boot=/dev/hde3
    default 0
    timeout 15
    splashimage=(hd0,2)/grub/splash.xpm.gz
    fallback 5
    title Fedora Core (2.6.7-1.494.2.2)
            root (hd0,2)
            kernel /vmlinuz-2.6.7-1.494.2.2 ro root=LABEL=/ rhgb quiet
            initrd /initrd-2.6.7-1.494.2.2.img
    title Windows_XP
    rootnoverify (hd0,0)
    chainloader +1
    Good luck and enjoy Linux!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •