Find the answer to your Linux question:
Results 1 to 3 of 3
I realize that 10.0 seriously changed the internet connection wizard from 9.2. In 10.0, it sets it up using Squid. I don't want to use a proxy. Here's my setup ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907

    ICS pain in my ass


    I realize that 10.0 seriously changed the internet connection wizard from 9.2. In 10.0, it sets it up using Squid. I don't want to use a proxy. Here's my setup

    box1 eth0 - 192.168.0.1
    eht1 - DHCP Cable modem

    box2 192.168.0.2
    box3 192.168.0.3

    I like Shorewall and am fairly comforable with it, the problem I have is in IP-Chains. Can I simple remove the forward to Squid and if so how? Should I just forward everything, and if so how? Is that secure?

    Thanks,
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You should be able to remove the rule telling it to forward to squid with no adverse affects other than your connection not working. Then all you'll have to do is enable forwarding. Typically, you would only allow connections with the ESTABLISHED or RELATED states (using the -m switch in your iptables rule).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Solved using kpzanis's fantastic tutorial:

    http://linuxforums.org/forum/viewtop...=114646#114646

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •