Find the answer to your Linux question:
Results 1 to 8 of 8
Mandrake 10.0, ATI Rage Mobility P I installed the MDK 10.0 rpm for Ati.2, but when I restarted X, I still didn't have 3D acceleration. So I installed the binary ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907

    Ati.2 Gatos - but no 3D accel


    Mandrake 10.0, ATI Rage Mobility P

    I installed the MDK 10.0 rpm for Ati.2, but when I restarted X, I still didn't have 3D acceleration. So I installed the binary tar-ball from the Gatos page. It says you only have to untar it and it should work. A little further down the page it says you have to configure, make, etc... but those files aren't in the tar-ball.

    So...

    1) If ATI.2 is installed, how do I configure it for 3D accel

    2) If it's not installed, what am I doing wrong?

    Thanks everyone!
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11
    Did you setup your X config file, i know for all nvidia card you have to do that.

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    How do I configure my X config file?

    Thanks,
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    have you searched /etc/X11/XF86config ?open it and edit..
    Linux For Ever!

  6. #5
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Thanks,

    But I don't know what to change in the X-Config file!

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  7. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Okay, here's where I'm at with the ATI drivers....

    I have an ATI Rage Mobilty M/P, Mandrake 10.0 running kernel 2.6. I installed the Gatos drivers, as ATI doesn't support the Mobilty series at their site. I have configured the Gatos drivers and their working fine. The only thing is that I can't use 3D acceleration. What I've read tells me to install the DRI modules from the Gatos site, but those require the DRM-Kernel. From what I understand, 2.6 is supposed to have DRM already configured, but it's not, and there's no DRM for 2.6! For 2.4, it was a seperate module. hmmmm....

    Now what do I do? I just want 3D acceleration!

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  8. #7
    Just Joined!
    Join Date
    Sep 2004
    Posts
    4
    I'm no help, but i'm in the same boat. i have a Radeon 7500 so i can't use normal ATI drivers from the site, and the fact that it's an all in wonder makes it more interesting. From Mandrake iI've tried installing drivers from Penguin Liberation Front via the package manager, but that doens't seem to help. 2d works ok, but it's the 3d that runs slowly. I think it's from trying to treat the AGP slot as PCI but i dont know for sure. doing a lsmod shows agpgart and radeon both have a nice big 0 next to them...

  9. #8
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •