Find the answer to your Linux question:
Results 1 to 3 of 3
I am trying to install apcupsd-3-14-3 on Mandriva Linux. I am getting the following response. Your help in resolving this problem is greatly appreciated. Will be glad to provide any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    18

    install error apcupsd-3-14-3


    I am trying to install apcupsd-3-14-3 on Mandriva Linux. I am getting the following response. Your help in resolving this problem is greatly appreciated. Will be glad to
    provide any additional info if needed.

    ++++++++++++++++++++

    [root@localhost apcupsd-3.14.3]# ./configure
    checking for true... /bin/true
    checking for false... /bin/false
    checking build system type... i686-pc-linux-gnuoldld
    checking host system type... i686-pc-linux-gnuoldld
    checking for gcc... gcc
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.

    +++++++++++++++++++++++++

    and here is a portion of 'config.log'

    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.

    It was created by configure, which was
    generated by GNU Autoconf 2.59. Invocation command line was

    $ ./configure

    ## --------- ##
    ## Platform. ##
    ## --------- ##

    hostname = localhost
    uname -m = i686
    uname -r = 2.6.22.18-desktop-1mdv
    uname -s = Linux
    uname -v = #1 SMP Mon Feb 11 13:53:50 EST 2008

    /usr/bin/uname -p = unknown
    /bin/uname -X = unknown

    /bin/arch = i686
    /usr/bin/arch -k = unknown
    /usr/convex/getsysinfo = unknown
    hostinfo = unknown
    /bin/machine = unknown
    /usr/bin/oslevel = unknown
    /bin/universe = unknown

    PATH: /sbin
    PATH: /usr/sbin
    PATH: /bin
    PATH: /usr/bin
    PATH: /usr/X11R6/bin
    PATH: /usr/local/bin
    PATH: /usr/local/sbin
    PATH: /usr/lib/qt3//bin


    ## ----------- ##
    ## Core tests. ##
    ## ----------- ##

    configure:1437: checking for true
    configure:1455: found /bin/true
    configure:1467: result: /bin/true
    configure:1482: checking for false
    configure:1500: found /bin/false
    configure:1512: result: /bin/false
    configure:1553: checking build system type
    configure:1571: result: i686-pc-linux-gnuoldld
    configure:1579: checking host system type
    configure:1593: result: i686-pc-linux-gnuoldld
    configure:1649: checking for gcc
    configure:1665: found /usr/bin/gcc
    configure:1675: result: gcc
    configure:1919: checking for C compiler version
    configure:1922: gcc --version </dev/null >&5
    gcc (GCC) 4.2.2 20071128 (prerelease) (4.2.2-3.1mdv2008.0)
    Copyright (C) 2007 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    configure:1925: $? = 0
    configure:1927: gcc -v </dev/null >&5
    Using built-in specs.
    Target: i586-mandriva-linux-gnu
    Configured with: ../configure --prefix=/usr --libexecdir=/usr/lib --with-slibdir=/lib --mandir=/usr/share/man --infodir=/usr/share/info --enable-checking=release --enable-languages=c,c++,ada,fortran,objc,obj-c++,java --host=i586-mandriva-linux-gnu --with-cpu=generic --with-system-zlib --enable-threads=posix --enable-shared --enable-long-long --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --enable-java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --enable-gtk-cairo --disable-libjava-multilib --enable-ssp --disable-libssp
    Thread model: posix
    gcc version 4.2.2 20071128 (prerelease) (4.2.2-3.1mdv2008.0)
    configure:1930: $? = 0
    configure:1932: gcc -V </dev/null >&5
    gcc: '-V' option must have argument
    configure:1935: $? = 1
    configure:1958: checking for C compiler default output file name
    configure:1961: gcc conftest.c >&5
    as: error while loading shared libraries: libbfd-2.17.50.0.12.so: cannot open shared object file: No such file or directory
    configure:1964: $? = 1
    configure: failed program was:
    | /* confdefs.h. */
    |
    | #define PACKAGE_NAME ""
    | #define PACKAGE_TARNAME ""
    | #define PACKAGE_VERSION ""
    | #define PACKAGE_STRING ""
    | #define PACKAGE_BUGREPORT ""
    | /* end confdefs.h. */
    |
    | int
    | main ()
    | {
    |
    | ;
    | return 0;
    | }
    configure:2003: error: C compiler cannot create executables
    See `config.log' for more details.

    ## ---------------- ##
    ## Cache variables. ##
    ## ---------------- ##

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    Looks like you need to install binutils. Try that and give it another go.
    I base this on the fact that 'as' in your log files can not open "libbfd-2.17.50.0.12.so" and googling that gives me that it should be part of the binutils package.

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    18
    Great! that worked. All I had to do was install "Make" to finish the installation.

    Thank you very much.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •