Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
HI all, Lots of posts today I just installed powerpack 2008 spring. And now I have quite a few problems, unfortunately. When I try to add a media using either ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86

    Urpmi problems (2008.1)


    HI all,
    Lots of posts today
    I just installed powerpack 2008 spring. And now I have quite a few problems, unfortunately. When I try to add a media using either the graphical interface or urpmi.addmedia it just freezes. Not giving any indication that anything is happening. When I type it in (as root) in a console I get no feedback at all. I can see on my modem that nothing is happening over the network either. I can access the site via firefox from the machine. And I have updated /etc/modprobe.conf to say 'install ipv6 /bin/true' (and rebooted) but no luck. What else can I try to make urpmi work?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    It's possible that your ISP doesn't support ipv6... If this is so, then urpmi won't work at all until you disable it. Just an idea.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    I thought that I had just disabled IPv6 with the mod probe change?
    I based this on the following
    Releases/Mandriva/2008.0/Errata - Mandriva Community Wiki
    So if that did not disable IPv6 (as I was lead to believe by that post in the wiki) how do I do that? I am pretty certain that ipv6 is the problem.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - I haven't seen that solution before. Try this instead:

    Check the contents of /etc/modprobe.conf by typing:

    more /etc/modprobe.conf

    See if there are any lines reading as follows:

    alias net-pf-10 off
    alias ipv6 off

    If not, add those lines to the file and save. Now try again.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    it was not there,
    so I removed the line I had added before and added those two lines, rebooted and hoped..
    but no. It made no difference. Still no success.

    Could it be a firewall issue? On my local machine that is, because I had 2007 on this machine before and it worked fine. I have a different machine on the same network running 2008 (free) and it works.

  7. #6
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    I disabled the local firewall, but that did not make a difference.
    I tired to add a specifc medium ('main') from a specific mirror ('riken.go.jp') as detailed on the easyurpmi site. When pasteing the command from the site it takes a while and then it says
    "Adding medium 'main'"
    Nothing more happens.
    I then run a 'netstat -all' and see that only one ftp connection is attemted, to 1.0.0.0! This is NOT the ip of riken!
    So it seems that it is a DNS problem,
    if I run ftp ftp.riken.go.jp it opens a connection and I can log in. So from the looks of it the urpmi program is not doing a proper name lookup of the addresses. Can anyone offer any insight into how to fix this?

  8. #7
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    Indeed! if I replace the domain name with the ip given by a 'nslookup' it works!
    It is a naming issue! Can anyone offer any insight into this?

  9. #8
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by daik View Post
    Indeed! if I replace the domain name with the ip given by a 'nslookup' it works!
    It is a naming issue! Can anyone offer any insight into this?
    Not sure of the exact cause, but a lot of urpmi problems seem to relate to ipv6 OR DNS issues. You did well to track it down, as I can remember struggling with similar issues.

    OpenDNS is worth looking at, if you have further issues. Firewalls are rarely to blame, even though they seem to be obvious culprits. For example, I run 2 firewalls: one on my router and the other built into Mandriva. This has never caused access problems of any kind.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  10. #9
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    I tried adding my local dns to the network config using the mandriva control center. I then removed my wireless network (not using it anyway right now, and I thought less is better when working through this). I rebooted to make sure all changes were implented properly. I then tried again but this did not help, it still tried to connecto to 1.0.0.0.

    I find this strange, because if I run a nslookup on this machine it gives me the correct ip, if I try to use wget to the given url, it downloads the file properly. BUT when run through urpmi it gets the wrong IP. Can I configure this somehow? Should I raise this as a bug with mandriva, or is it more a problem with me rather than the program.

    Thank you for all your help, it has been good to get some thoughts around this.

  11. #10
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    I had a look in /etc/nsswitch.conf and noticed NIS was listed before DNS, since I don't run NIS I moved it to be after DNS, that did not do anything unfortunately. In the end I added the hosts into my /etc/hosts file and it worked. Not ideal, but I suppose it will be fine for the time being.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •