Find the answer to your Linux question:
Results 1 to 4 of 4
HI. I Am Still A Newbie But I Know A Lot actually, What happend, i installed UT2004 For Linux Onto My Computer And I Will Show The Log: Code: [wykis@localhost ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    11

    Cant Start Unreal Tournament 2004 On mandrake Linux 10


    HI.
    I Am Still A Newbie But I Know A Lot
    actually, What happend, i installed UT2004 For Linux Onto My Computer And I Will Show The Log:
    Code:
    [wykis@localhost wykis]$ cd ut2004
    [wykis@localhost ut2004]$ ./ut2004
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    WARNING: ALC_EXT_capture is subject to change!
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
     
     
    History:
     
    Exiting due to error
    [wykis@localhost ut2004]$
    I Dont Know What TO Do... I Maybe Just Wasting My Time
    My Computer Is
    CPU Amd Athlon XP 2700+
    nForce Motherboard
    integrated nVidia GeForce Mx 4 64Mb Video Card
    Mandrake Linux 10
    PnP 15" LCD Monitor ( 1024 x 768 )

    Unreal Tournament Works On Windows Well Good

  2. #2
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Greece
    Posts
    187
    You just need to install nvidia drivers and enable 3d acceleration.To do that go to nvidia site download nvidia linux drivers (IA 32) AND THEN login as root edit type in aconsole init 3 then type go to the folder nvidia driver is and type sh (THE FILENAME OF THE DRIVER) FOLLOW THE INSTRUCTIONS AND WHEN IS OVER OPEN YOUR /etc/X11/XF86config and in section Device change the driver nv to nvidia.REBOOT and ok

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Greece
    Posts
    187
    Also i forget in your /etc/X11/XF86config in modules section delete the line Load "dri" and add if there is not the line Load "glx"

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    10

    hi

    hi there,

    i've got a lookalike problem, but with an ati card (radeon 9600)
    i've tried many things to get it started, but without succes.

    I'm working with Mandrake 10 on a asus a7n8x-e deluxe motherboard.
    I've bought UT2004 (2dvd's) so i can play under linux, used to play under windows
    i've added the load "dri" as mentioned on many forums.


    Can anyone help me? i'd joined a ut2004 clan, but i'm unable to play

    EDIT:
    i'm getting as example this error:

    Xlib: extension "XFree86-DRI" missing on display ":0.0".

    This error will occur even with glxgears


    kind regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •