Find the answer to your Linux question:
Results 1 to 8 of 8
Can anyone help me with installing java software from sourcecode. I see a lot of nice programs I would like to download but I pass them by because I can't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dnr01's Avatar
    Join Date
    Jul 2008
    Posts
    5

    Installing Java Software


    Can anyone help me with installing java software from sourcecode. I see a lot of nice programs I would like to download but I pass them by because I can't seem to get the hang of Java installs. I have installed the latest version of Java from their websit so shouldn't I have everything I need to do an install.

    Thanks

  2. #2
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    which programs are you trying to install

  3. #3
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    If you let us know how exactly you setup java, which apps you tried to install and where exactly you experienced difficulties, we maybe able to help.

  4. #4
    Just Joined! dnr01's Avatar
    Join Date
    Jul 2008
    Posts
    5
    I've been trying to install a program (one of many java based programs) called SnortKonsole and when I run a java <filename> I get this

    [root@localhost SnortKonsole-0.1]# java SnortKonsole-0.1.jar
    Exception in thread "main" java.lang.NoClassDefFoundError: SnortKonsole-0/1/jar
    Caused by: java.lang.ClassNotFoundException: SnortKonsole-0.1.jar
    at java.net.URLClassLoader$1.run(URLClassLoader.java: 220)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.j ava:20
    at java.lang.ClassLoader.loadClass(ClassLoader.java:3 23)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:2 6
    at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:336)
    Error: Could not find the main class.
    Error: A JNI error has occurred, please check your installation and try again
    [root@localhost SnortKonsole-0.1]#

    By the way, I am running Mandriva 2008.1

    Thanks

  5. #5
    Just Joined! dnr01's Avatar
    Join Date
    Jul 2008
    Posts
    5
    Also this is all I know about what I have installed for java.

    [root@localhost SnortKonsole-0.1]# java -version
    openjdk version "1.7.0-internal"
    OpenJDK Runtime Environment (build 1.7.0-internal-b24)
    OpenJDK Client VM (build 1.7.0-b24, mixed mode)

    That doesn't mean much to me but I hope it helps you guys.

    Thanks

  6. #6
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    if i'm not mistaken i think you run a java app with the command java -jar app-name.jar

  7. #7
    Just Joined! dnr01's Avatar
    Join Date
    Jul 2008
    Posts
    5
    Thanks, that worked to get the program running. Now I know.

  8. #8
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    glad i could help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •