Find the answer to your Linux question:
Results 1 to 4 of 4
Today I booted up Mandriva 2008.0 entering my username and password as normal. However, once the GUI appeared the keyboard ceased to work. I rebooted into Windows and the keyboard ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35

    Keyboard not working in KDE Mandriva 2008.0


    Today I booted up Mandriva 2008.0 entering my username and password as normal. However, once the GUI appeared the keyboard ceased to work.

    I rebooted into Windows and the keyboard worked normally.
    I then rebooted into Mandriva with the ICEWM deskto and the keyboard functioned as usual. It also works in Safe Mode.

    My Xorg.conf reads as follows and seems unchanged .

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
    Option "XkbOptions" "compose:rwin"
    EndSection

    Ideas on how to rectify this problem would be appreciated.

    Many thanks

    Tony Littlejohn

  2. #2
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    Hi,

    I had the same problem today with Mandriva 2008.1. Having used the PC yesterday and not turned it off overnight I was amazed to find that the keyboard appeared to be dead. After rebooting into Gnome, as you tried in another GUI, everything worked fine. So the problem is definitely in KDE. I have a home built AMD 64 X2 box with an NVIDIA video card and have checked the config and nothing appears to have changed.
    I went through the Mandriva formums and found a few suggestions regarding the NVIDIA conf and even a suggestion that it could be due to nfs drives but so far nothing works to correct the problem.
    As your problem was logged over 24 days ago I was wondering if you had found a solution other than having to re-load everything?

    I hope you have.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35

    Keyboard Fails to work

    Colinet,
    I must admit that I finally gave up with trying to solve the keyboard problem and went all the way back to 2008.0. I chose 2008.0 because of the PulseAudio Skype "no sound" problem.

    I then tried out 2009 - the download ONE version. It looked good but for me was too unstable. So it was back to 2008.0 again and I'm staying here until 2009 is more stable. Perhaps the Spring version will do the job.

    I have tried Gnome in the past but overall prefer KDE.

    Sorry that I can't help you.

    Tony

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3

    Smile Success!

    I decided to have another go at this problem and having logged in via Gnome carried up an update through MCC. I then followed up a suggestion from elsewhere and deleted the /home/.kde folder. Restarted back to KDE and remarkably the keyboard was back in action.

    Needless to say I had to reset all the KDE setting back but it was worth it to avoid having to reload Mandriva completely.

    Colin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •