Find the answer to your Linux question:
Results 1 to 5 of 5
Hello. Last weekend i finally got and installed Linux Mandrake 10 Community (download version). The installation and configuration was a piece of cake. Put aside problems with dual boot which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    Croatia, Zagreb
    Posts
    70

    PCtel HSP56 MR modem in MDK10 (kernel 2.6.3-4)


    Hello.

    Last weekend i finally got and installed Linux Mandrake 10 Community (download version). The installation and configuration was a piece of cake. Put aside problems with dual boot which i caused by having the third OS installed (BeOS).
    Anyway.. all hardware is working fine except modem and Lexmark X75 AllInOne printer with scanner.

    However, what's very important to me isn't printer right now, but a modem for which i gotta make it working under my new linux so i can finally have it as my primary system. It's too beautiful not to have it as my primary OS for which internet connection is a must.

    Here's my data and i hope anyone can help:

    modem is:

    PCtel HSP56 MR Data/Fax/Voice
    it seem's it's on sis 7013 chipset or subsystem
    it came with my crappy PCCHIPS M810 LMR mainboard with sis730s chipset (actually same as sis630/730) and it's located in AMR slot (Audio Modem Riser).

    I googled over whole web, read the relevant pages of linmodems.org site, downloaded and tried smartlink smlmodemd (smbmdm), installed it by the book, but still getting BUSY errors.
    I then tried the newest version of PCTEL driver provided and linmodem, the PCTEL v2.9.9-7, but it say's it's only for kernels 2.4.x which seems to be the main problem here.
    I could probably get it working with that if it only supported the new 2.6.3 kernel.
    Any help is very appreciated.
    And my specific question is are there and where drivers that are compatible with linux kernel 2.6.3-4 on Mandrake 10??

    Thank you very much!
    Daniel

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    Croatia, Zagreb
    Posts
    70
    Okay.. now i tried with slmodem drivers, followed the steps again, this time more carefully and understanding more.

    Everything goes fine as with loading the driver with "modprobe slamr" and then running the slmodem program with "/usr/sbin/slmodem /dev/slamr0"

    It then shows that it created the "/dev/ttySL0" which points to "/dev/pts/1". It also says that i should set ttySL0 at my dialing program which is kppp.
    However, i looked at those directories where those files should be created and there are non of it, nor ttySL0 nor "1" file inside that pts folder. So it seems it's "lieing" or something. It said it created it, but it didn't (slmodem) which may exactly be why i cannot connect. I get the "modem is busy" on query and if trying to connect.

    So, it seems that the current problem here is why the heck does it not create those files inside /dev folder?

    Besides this slmodem option which seemed to work for many using similar modems as mine (as i read), there's a remaining option i would love to avoid, downgrading linux kernel 2.6.3-4 to 2.4.xx since there is a driver that supports that version, but not the new 2.6, and that has a great chances of working (it's made for these pctel modems).

    Anyone knows anything that might help in this situation?

    Thank you very much!
    Daniel

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Location
    Croatia, Zagreb
    Posts
    70
    Hello!

    I actually did it, slmodem driver works as i am typing this while being connected through my beautiful Linux Mandrake 10

    Now, it can be my primary system.. goodbye windows!

    The last remaining issue to resolve is autoloading the driver. I need it to do the following automatically at startup:
    Code:
    modprobe slamr (which loads the module)
    /usr/sbin/slmodemd --country=SLOVENIA (re-creates the ttySL0 linking to /pts/1)
    Without the autoloading script i must do that myself in konsole everytime i want to connect.

    I already have this startups script:

    Code:
    #!/bin/sh
    #
    # slmodemd:    Starts the SmartLink Modem Daemon
    #
    # chkconfig: 345 90 10
    # description: SmartLink Modem : Autoload slarm + slmodem
    # processname: slmodemd
    # config: /etc/sysconfig/slmodem
    
    # Source function library.
    . /etc/init.d/functions
    
    prog=slmodemd
    RETVAL=0
    
    # Default configuration
    SLMODEMD_DEVICE=slamr0
    SLMODEMD_COUNTRY=SLOVENIA
    
    # Source configuration
    CONFIG=/etc/sysconfig/$prog
    if [ -f $CONFIG ]; then
            . $CONFIG
    fi
    
    # uncomment this if you want this feature (if necessary edit module pattern):
    # do not try to start on a kernel which does not support it
    # grep -q 'slamr\.o' /lib/modules/`uname -r`/modules.dep || exit 0
    
    start() {
    	cat /proc/modules | grep 'slamr' >/dev/null || {
    	  echo -n "Loading SmartLink Modem driver into kernel ... "
    	  modprobe slamr && echo "done." || { 
    	    echo "failed."
    	    exit -1
    	  }
    	}
    	echo -n "Starting SmartLink Modem driver for $SLMODEMD_DEVICE: "
    	# if you want ALSA comment next line and uncomment last
    	$prog </dev/null >/dev/null 2>/dev/null --country=$SLMODEMD_COUNTRY /dev/$SLMODEMD_DEVICE &
    	# $prog </dev/null >/dev/null 2>/dev/null --country=$SLMODEMD_COUNTRY --alsa /dev/$SLMODEMD_DEVICE &
    	RETVAL=$?
    	&#91; $RETVAL -eq 0 &#93; && success $"$prog startup" || failure $"$prog startup"
    	echo
    	&#91; $RETVAL -eq 0 &#93; && touch /var/lock/subsys/$prog
    	return $RETVAL
    &#125;
    
    stop&#40;&#41; &#123;
    	echo -n "Shutting down SmartLink Modem driver&#58; "
    	killproc $prog
    	RETVAL=$?
    	modprobe -r slamr slusb
    	echo
    	&#91; $RETVAL -eq 0 &#93; && rm -f /var/lock/subsys/$prog
    	return $RETVAL
    &#125;
    
    # See how we were called.
    case "$1" in
      start&#41;
    	start
    	;;
      stop&#41;
    	stop
    	;;
      status&#41;
    	status $prog
    	RETVAL=$?
    	;;
      restart|reload&#41;
    	stop
    	start
    	RETVAL=$?
    	;;
      condrestart&#41;
            if &#91; -f /var/lock/subsys/$prog &#93;; then
    		stop
    		start
    		RETVAL=$?
    	fi
    	;;
      *&#41;
    	echo "*** Usage&#58; $prog &#123;start|stop|status|restart|condrestart&#125;"
    	exit 1
    esac
    
    exit $RETVAL
    Where should i place it for it to load on startup and is it ok to do it?
    Maybe it'll be better to just configure the startup to do those modprobe and slmodemd commands as described above. (the ones that i do manually).

    Thank you.
    Daniel

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2004
    Location
    INDIA
    Posts
    4
    for making something to start @ start-up we should keep it in

    "rc.d" directory..in that directory there is a file "rc.local" ( or something with local word in it..)..

    just paste your scripts in that file if you want to get them running @ start-up..

    i hope this may help..

    thanks.

  6. #5
    Just Joined!
    Join Date
    May 2008
    Posts
    2
    Thanks anyway but I just got a linmodem and it works great. I was thinking about it and I want to try a bunch of distros, so it just made sense to get something that would be likely to work with all of them. The modem I got is supposed to be very versatile. Marc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •