Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I found some themes I'm interested in installing on my system, however, everytime I try to install the gtk+-1.2.8 file, it says I need glib 1.2.8 or better. Here's where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    67

    Installing new theme


    I found some themes I'm interested in installing on my system, however, everytime I try to install the gtk+-1.2.8 file, it says I need glib 1.2.8 or better. Here's where my problem is. It's saying I need glib 1.2.8 or later, but I installed glib 2.10.3 already, so if I have the latest version of glib, why won't it run the gtk file and why does it keep saying I need to upgrade the glib when it's already at latest version? Someone please help.

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    GTK 1.x and GLIB 1.x are not the same as GTK 2.x and GLIB 2.x. You need to install the GLIB 1.x package which should be in the Mandriva software repositories.

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    67
    I checked and I have glib 1.2.8 installed. Plus, I just downloaded and install glib 1.2.9, yet, when I tried to install gtk 1.2.8 again, it still gave me the message I need glib 1.2.8 or later. Why won't it install? Do I need to maybe uninstall glib 1.2.8 for it to recongnize the later version I installed?

  4. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Can you post the exact error messages as well as the output of running
    Code:
    rpm -qa | grep -i gtk

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    67
    I went into gtk+-1.2.8 directory then typed "./configure" command and got this:

    loading cache ./config.cache
    checking for a BSD compatible install... (cached) /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... (cached) yes
    checking for working aclocal... missing
    checking for working autoconf... missing
    checking for working automake... missing
    checking for working autoheader... missing
    checking for working makeinfo... missing
    checking host system type... i686-pc-linux-gnu
    checking build system type... i686-pc-linux-gnu
    checking for ranlib... (cached) ranlib
    checking for gcc... (cached) gcc
    checking whether the C compiler (gcc ) works... yes
    checking whether the C compiler (gcc ) is a cross-compiler... no
    checking whether we are using GNU C... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for ld used by GCC... (cached) /usr/bin/ld
    checking if the linker (/usr/bin/ld) is GNU ld... (cached) yes
    checking for BSD-compatible nm... (cached) /usr/bin/nm -B
    checking whether ln -s works... (cached) yes
    loading cache ./config.cache within ltconfig
    checking for object suffix... o
    checking for executable suffix... (cached) no
    checking for gcc option to produce PIC... -fPIC
    checking if gcc PIC flag -fPIC works... yes
    checking if gcc supports -c -o file.o... yes
    checking if gcc supports -c -o file.lo... yes
    checking if gcc supports -fno-rtti -fno-exceptions ... no
    checking if gcc static flag -static works... none
    checking if the linker (/usr/bin/ld) is GNU ld... yes
    checking whether the linker (/usr/bin/ld) supports shared libraries... yes
    checking command to parse /usr/bin/nm -B output... ok
    checking how to hardcode library paths into programs... immediate
    checking for /usr/bin/ld option to reload object files... -r
    checking dynamic linker characteristics... Linux ld.so
    checking if libtool supports shared libraries... yes
    checking whether to build shared libraries... yes
    checking whether to build static libraries... yes
    checking for objdir... .libs
    creating libtool
    loading cache ./config.cache
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking host system type... i686-pc-linux-gnu
    checking whether build environment is sane... yes
    checking for gcc... (cached) gcc
    checking whether the C compiler (gcc -g -O2 ) works... yes
    checking whether the C compiler (gcc -g -O2 ) is a cross-compiler... no
    checking whether we are using GNU C... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for POSIXized ISC... no
    checking for gcc option to accept ANSI C... none needed
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether make sets ${MAKE}... (cached) yes
    checking for mawk... no
    checking for gawk... gawk
    checking for perl5... perl5
    checking for indent... no
    checking whether make is GNU Make... yes
    checking how to run the C preprocessor... gcc -E
    checking for ANSI C header files... yes
    checking for working const... yes
    checking for inline... inline
    checking for off_t... yes
    checking for size_t... yes
    checking for working alloca.h... yes
    checking for alloca... yes
    checking for unistd.h... yes
    checking for getpagesize... yes
    checking for working mmap... no
    checking for argz.h... yes
    checking for limits.h... yes
    checking for locale.h... yes
    checking for nl_types.h... yes
    checking for malloc.h... yes
    checking for string.h... yes
    checking for unistd.h... (cached) yes
    checking for sys/param.h... yes
    checking for getcwd... yes
    checking for munmap... yes
    checking for putenv... yes
    checking for setenv... yes
    checking for setlocale... yes
    checking for strchr... yes
    checking for strcasecmp... yes
    checking for strdup... yes
    checking for __argz_count... yes
    checking for __argz_stringify... yes
    checking for __argz_next... yes
    checking for stpcpy... yes
    checking for LC_MESSAGES... yes
    checking whether NLS is requested... yes
    checking for libintl.h... yes
    checking for dgettext in libc... yes
    checking for msgfmt... /usr/bin/msgfmt
    checking for dcgettext... yes
    checking for gmsgfmt... /usr/bin/msgfmt
    checking for xgettext... /usr/bin/xgettext
    checking for catalogs to be installed... ca cs da de el es et eu fi fr ga gl hr hu it ja ko lt nl no nn pl pt pt_BR ro ru sk sl sv uk wa zh_TW.Big5
    checking for extra flags to get ANSI library prototypes... none needed
    checking for extra flags for POSIX compliance... none needed
    checking for glib-config... /usr/local/bin/glib-config
    checking for GLIB - version >= 1.2.8...
    *** 'glib-config --version' returned 1.2.8, but GLIB (1.2.10)
    *** was found! If glib-config was correct, then it is best
    *** to remove the old version of GLIB. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG
    *** to point to the correct copy of glib-config, and remove the file config.cache
    *** before re-running configure
    no
    configure: error:
    *** GLIB 1.2.8 or better is required. The latest version of GLIB
    *** is always available from ftp://ftp.gtk.org/.


    After typing "rpm -qa | grep -i gtk" I got this:

    libgtkmm2.4_1-2.12.7-1mdv2008.1
    libgtk-engines2-2.14.0-1mdv2008.1
    libgtk+-x11-2.0_0-2.12.9-2mdv2008.1
    libgtkspell0-2.0.11-3mdv2008.1
    libgtk-linux-fb-2.0_0-2.4.14-6mdk
    libgtksourceview-1.0_0-1.8.5-4mdv2008.1
    perl-Gtk2-Sexy-0.02-2mdv2008.1
    libgtkhtml-3.14_19-3.18.0-1mdv2008.1
    gtksourceview-2.2.0-1mdv2008.1
    libwxgtku2.6-2.6.4-14mdv2008.1
    libgtk+2.0_0-2.12.9-2mdv2008.1
    pygtk2.0-2.12.1-1mdv2008.1
    pygtk2.0-libglade-2.12.1-1mdv2008.1
    libgtkimageview0-1.5.0-1mdv2008.1
    gtksourceview1-1.8.5-4mdv2008.1
    gtkhtml-3.14-3.18.0-1mdv2008.1
    libgtksourceview-2.0_0-2.2.0-1mdv2008.1
    galaxy-gtk12-1.0.6-1mdv2008.1
    wxgtk2.8-2.8.7-1mdv2008.1
    libgtkhtml2_0-2.11.1-2mdv2008.1
    python-gtksourceview-2.2.0-1mdv2008.1
    compiz-decorator-gtk-0.7.2-3mdv2008.1
    xdg-user-dirs-gtk-0.7-2mdv2008.1
    wxGTK2.6-2.6.4-14mdv2008.1
    gtkspell-2.0.11-3mdv2008.1
    perl-Gtk2-Html2-0.04-9mdv2008.1
    gnome-python-gtkmozembed-2.19.1-10.4mdv2008.1
    gtk+2.0-2.12.9-2mdv2008.1
    perl-Gtk2-1.173-1mdv2008.1
    perl-Gtk2-SourceView-1.000-7mdv2008.1
    perl-Gtk2-Notify-0.04-2mdv2008.1
    gtk-sharp2-2.12.0-1mdv2008.1
    gtk-engines2-2.14.0-1mdv2008.1
    task-3ddesktop-gtk-2008.1-1mdv2008.1
    pinentry-gtk-0.7.5-1mdv2008.1
    libgtk+1.2-1.2.10-48mdv2008.1
    libwxgtku2.8-2.8.7-1mdv2008.1

    Hopefully you understand that better than I do. If I need to remove/uninstall anything, please give me the command to do so cause I know how to install, but I have yet to learn to uninstall. Thanks for your help.

  6. #6
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    You are missing the development (devel) files for glib 1.x and gtk 1.x. Install them by running (as root) the commands below in a terminal
    Code:
    urpmi libglib1.2-devel libgtk+1.2-devel
    After that run ./configure again

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    67
    I used the command "urpmi libglib1.2-devel" and it worked perfectly. The package installed. I tried "urpmi libgtk+1.2-devel" and got the message "No package named libgtk+1.2-devel". I even tried a search in the add/remove programs area for packages and no luck. Is there another way I can get the package? Also, I'm trying to install KDM and/or Gnome theme managers (whichever works for me)..but I keep having troubles there too. I downloaded KDE theme manager, extracted it and use ./configure command in the directory, but it says "The impoartant program kde-config was not found! Please check whether you installed KDE correctly". Well, I already have KDE installed..it came with the OS...have any ideas on what I can do? Also, I downloaded Gnome themes 2.14.1 and when I typed ./configure in the extracted directory, it says I need gtk-engines-2.15.3 to install Gnome theme manager..but I looked and can only find 2.14.0 which I currently have installed. There a way around this? Nothing seems to be working for me on here right now.

  8. #8
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    It seems like in some newer versions of Mandriva, the gtk 1.x development package was renamed to libgtk+-devel. You also need to install the KDE development files (the devel files for kdelibs and probable kdebase) in order to compile apps against KDE).

    Out of curiosity, what version of Mandriva are you using? In Mandriva 2009, the version of gtk-engines is 2.16.

  9. #9
    Just Joined!
    Join Date
    Sep 2008
    Posts
    67
    Thanks for that little bit of extra info. I was able to install the libgtk+-devel and kdebase packages. I tried "urpmi kdelibs-devel" and got this message:

    The following packages can't be installed because they depend on packages
    that are older than the installed ones:
    libldap2.4_2-devel-2.4.8-2.1mdv2008.1
    libkdecore4-devel-3.5.9-10.1mdv2008.1
    Continue installation anyway? (Y/n) n

    I chose "no". I didn't wanna screw anything up. Or should I install the package anyway? After installing the kde package, I figured it would be worth another try and I ran ./configure command in the "kdmtheme" directory again and I got this:

    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking target system type... i686-pc-linux-gnu
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for -p flag to install... yes
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for kde-config... /usr/bin/kde-config
    checking where to install... /usr (as returned by kde-config)
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking dependency style of gcc... gcc3
    checking how to run the C preprocessor... gcc -E
    checking for g++... no
    checking for c++... no
    checking for gpp... no
    checking for aCC... no
    checking for CC... no
    checking for cxx... no
    checking for cc++... no
    checking for cl... no
    checking for FCC... no
    checking for KCC... no
    checking for RCC... no
    checking for xlC_r... no
    checking for xlC... no
    checking whether we are using the GNU C++ compiler... no
    checking whether g++ accepts -g... no
    checking dependency style of g++... none
    checking whether gcc is blacklisted... no
    checking whether g++ supports -Wmissing-format-attribute... no
    checking whether gcc supports -Wmissing-format-attribute... yes
    checking whether g++ supports -Wundef... no
    checking whether g++ supports -Wno-long-long... no
    checking whether g++ supports -Wnon-virtual-dtor... no
    checking how to run the C++ preprocessor... /lib/cpp
    configure: error: C++ preprocessor "/lib/cpp" fails sanity check
    See `config.log' for more details.

    C++ error? What does that mean? Do I still need to install a later version of kdelibs-devel package for it to work? To answer your question, I'm running Mandriva Spring 2008. I tried '09 version, but it refused to boot on my system so I tried '08 version cause it was the second latest version available and it worked. Thanks for all your help. I greatly appreciate it. I'm getting use to linux and doing better with commands, but still having trouble understanding packages and how to know which packages are needed for what and there names.

  10. #10
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    From the looks of it, you did not install most of the required dependencies including gcc, needed to compile packages from source. You need to run the package manager (the GUI version is probably better for this) and search for gcc, glibc-devel. As for the the devel version of kdelibs and kdebase, just search for kde and you should see them listed in the results.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •