Hi all

I'm having an odd problem with cvspserver

I can use cvs no problem locally. I've setup the repository and every as far as I can tell is ready to roll for pserver connection but when I try this is what happens.

cvs -d server:dmcmillan@192.168.2.33:/usr/local/cvsroot/ login
Logging in to server:dmcmillan@192.168.2.33:2401/usr/local/cvsroot
CVS password:
/usr/local/cvsroot: no such repository

just for giggles I tried it with localhost instead of the ip and same thing.

I get the same error when connecting from another machine.

Here's what's in /etc/xinetd.d/cvs:

# CVS configuration for xinetd don't forget to specify your CVSROOT in
# /etc/cvs/cvs.conf.

service cvspserver
{
disable = no
socket_type = stream
protocol = tcp
wait = no
user = cvs
log_type = FILE /var/log/cvspserver
log_on_failure += USERID
server = /usr/sbin/cvspserver
server_args = -f --allow-root=/usr/local/cvsroot pserver
}

the directory /usr/local/cvsroot ownership and group are cvs cvs
all the subdirs and files are the same
I've already chmoded it hoping that would do something, but to no avail.

the passwd file in /usr/local/cvsroot/CVSROOT contains
dmcmillan::cvs

the syslog output is this:

Sep 8 14:22:54 localhost cvs: login refused for /usr/local/cvsroot

what I don't get is why there's no error concerning this when I run the cvs command
same thing happens if I try to use one of the local users.

Any suggestions?