Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
when i upgraded to 2009 i no longer can mount NTFS drives. how can i get this distro to do this. thanks Bower...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    168

    Mounting NTFS Paritions


    when i upgraded to 2009 i no longer can mount NTFS drives. how can i get this distro to do this. thanks Bower

  2. #2
    Just Joined!
    Join Date
    Nov 2008
    Posts
    26
    As root type drakdisk. or go through the control centre.

    If the disk is already configured it will need to be told to allow "Users" to mount

    Select the partition/disk in question then press Toggle expert mode button then Options.

    In the list check the "Users" box. ( It gives a brief description next to them)
    Save changes to fstab when asked
    Then try it

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Open Terminal or Konsole and execute this
    Code:
    su -
    fdisk -l
    df -h
    Post output here.

    * Its small L in fdisk -l.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    168

    results

    I would like to start all over i think and all but i am afraid i will lose alot if i do. is there a way to get this working


    fdisk -l

    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000d469a

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 12748 102398278+ 7 HPFS/NTFS
    /dev/sda2 12749 19456 53882010 f W95 Ext'd (LBA)
    /dev/sda5 12749 19456 53881978+ 7 HPFS/NTFS

    Disk /dev/sdb: 203.9 GB, 203928109056 bytes
    255 heads, 63 sectors/track, 24792 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xbac2bac2

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 1019 8185086 83 Linux
    /dev/sdb2 1020 24792 190956622+ 5 Extended
    /dev/sdb5 1020 1528 4088511 82 Linux swap/ Solaris
    /dev/sdb6 1529 12044 84469738+ 83 Linux
    /dev/sdb7 12045 13063 8185086 83 Linux
    /dev/sdb8 13064 13572 4088511 82 Linux swap/ Solaris
    /dev/sdb9 13573 24792 90124618+ 83 Linux

  6. #5
    Just Joined!
    Join Date
    Nov 2008
    Posts
    26
    We will get you sorted so don't worry

    See if it mounts at all, all as root
    Code:
    mkdir /mnt/win_c
    Code:
    mount -t ntfs /dev/sda1 /mnt/win_c
    If there's errors post them up
    If not unmount it with
    Code:
    umount /mnt/win_c
    You dont need to do all of the above but it will tell you if it works or not.

    Go to drakdisk as said before, highlight the "sda" tab

    It should be blue, highlight the partition. then "mount point" on the right. chose what/where ect..(drop down box)
    Then press mount.

    Save ect....
    Do the same for the second partition(D drive on windoze)

  7. #6
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    168

    report

    first command i get this error

    mkdir /mnt/win_c
    mkdir: cannot create directory `/mnt/win_c': File exists

    other two goes back to a prompt.

    Bower

  8. #7
    Just Joined!
    Join Date
    Nov 2008
    Posts
    26
    That just means its already created.

    If the other 2 went back to the prompt means it did it without errors.

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    How Linux distros have you installed? In any case, there is no need to create more than one SWAP partitions and you have two SWAP partitions already.

    Anyways, you haven't posted output of df -h command here.
    Execute this
    Code:
    su -
    cd /media
    mkdir win_c win_d
    Open /etc/fstab file with root privileges.
    Code:
    su -
    nano /etc/fstab
    Add this code at the end of file :
    Code:
    /dev/sda1  /media/win_c  ntfs  defaults,umask=0  0  0
    /dev/sda5  /media/win_d  ntfs  defaults,umask=0  0  0
    Press Ctrl + X, Y and hit enter key to save file.

    In case, nano throws an error, use any other text editor.

    Execute mount -a command or reboot machine. Check /media/win_c and win_d folders. You won't have to execute mount again and partitions will be mounted at boot up automatically.
    Last edited by devils casper; 12-07-2008 at 02:12 PM.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    168

    this is the results

    i have a couple distros but used virtual box to have others i think when i tried to upgrade my 2008.1 spring to 2009 id made a huge mess so nothing was working. i installed 2009 free to use and try and recover some of my files. i could not read anything from the other distro so i got a copy on mandriva 1 then i could go into the tatched upgrade and get my files. the new 2009 seems like it has issues too so i want to just clean start it and go fresh with 2009 but i need one place to put all my files i want to keep

    here is the results of what you asked for


    # mount -a
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda1': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sda1 /mnt/win_c -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sda1 /mnt/win_c ntfs-3g force 0 0
    $LogFile indicates unclean shutdown (0, 1)
    Failed to mount '/dev/sda5': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sda5 /mnt/win_d -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sda5 /mnt/win_d ntfs-3g force 0 0
    mount: special device /dev/sda3 does not exist
    [root@localhost travis]# rm -f /var/lib/urpmi/.RPMLOCK/dev/sda1 /media/win_c ntfs defaults,umask=0 0 0
    rm: cannot remove `/media/win_c': Is a directory
    [root@localhost travis]# /dev/sda3 /media/win_d ntfs defaults,umask=0 0 0
    bash: /dev/sda3: No such file or directory

    can you help me get this all cleaned up. and get a mandriva 2009 working and tuned up. i am still a newbe at all of this Bower

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the output of df -h command here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •