Find the answer to your Linux question:
Results 1 to 4 of 4
Mandriva linux 2009, One (dont have gcc installed). First of all, i do not have internet in linux, so i can't use install and remove manager to download .rpm files ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    3

    [SOLVED] How to install gcc in mandriva 2009 (with NO internet @linux)?


    Mandriva linux 2009, One (dont have gcc installed).
    First of all, i do not have internet in linux, so i can't use install and remove manager to download .rpm files =/ And i won't have it any time soon

    What i've tried is searching for .rpm files in the net, but everything i found belonged to other versions (like mandriva 2007 or 2008 ) and failed to install. I also tried to install as explained in here: Installing GCC - GNU Project - Free Software Foundation (FSF)
    but it seems to be really complicated, and there was this phrase: "when configuring a native system, either cc or gcc must be in your path or you must set CC in your environment before running configure. Otherwise the configuration scripts may fail. " seems like it needs a compiler in the system for installation, so it doesnt work for me since i dont have a compiler.

    I guess the easiest way would be getting .rpm file of gcc for mandriva 2009 but i just fail to find it. Can you give me link or offer another way to solve this? Thanks in advance.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    Yes, you'd need to find the rpm version of gcc that you wish to install, and you will need all of its dependencies installed in order to complete the rpm installation. You might run into the often encountered rpm (or dependency) hell issue while trying this.

    With any luck, perhaps you can find what you need on the Mandriva installation disk. I don't run Mandriva or have the disk on hand so can't check it for you.

    In the interim, maybe someone else can post a more specific solution for you.
    oz

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    3
    I need this really fast so i guess another solution is installing mandriva 2008 or 2007, cause i do have .rpm files for them already. Can someone give me torrent link to 2008 ??? it seems everywhere it's only 2009 now =/

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2008
    Posts
    3
    ok, i've installed gcc, finally. it requires lots of packages so i had to reboot and dl from windows 100 times =/

    in case u need this set of packages required to install gcc:

    manbo-mandriva-files-gcc-4.3.2-1mnb2.i586.rpm
    glibc-devel-2.8-1.20080520.5mnb2.i586.rpm
    kernel-headers-2.6.27-4mnb2.i586.rpm
    binutils-2.18.50.0.8-1mnb2.i586.rpm
    libbinutils2-2.18.50.0.8-1mnb2.i586.rpm

    actually the list is visa versa - u have to install libbinutils then binutils etc
    everything available at ftp://ftp.free.fr/mirrors/ftp.mandri.../main/release/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •