Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Dear all Mandrivians, How do you do? I wanted to use Player-stage in my research. When I was configuring the app using ./configure, there were lots of dependencies unavailable. I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    8

    Player/Stage dependencies


    Dear all Mandrivians,

    How do you do?
    I wanted to use Player-stage in my research. When I was configuring the app using ./configure, there were lots of dependencies unavailable.
    I'm using Mandriva 2008.0 on and connected to the internet and local HD for repos. So, I tried to install them but,most of all were not provided in the repo. I even add the 2009.0 repo in my collection.
    The problem is, the list of all dependencies needed were shown in their 'nickname'. Thus I had trouble to search what kind of app was that in the internet.

    Please, help me. At least for the full name of the apps. Even better if you can provide the url to follow
    Here are the list of the dependencies (filtered from konsole):


    g++... no
    c++... no
    gpp... no
    aCC... no
    CC... no
    cxx... no
    cc++... no
    cl.exe... no
    FCC... no
    KCC... no
    RCC... no
    xlC_r... no
    xlC... no
    dlfcn.h usability... no
    dlfcn.h presence... no
    dlfcn.h... no
    g77... no
    xlf... no
    f77... no
    frt... no
    pgf77... no
    cf77... no
    fort77... no
    fl32... no
    af77... no
    xlf90... no
    f90... no
    pgf90... no
    pghpf... no
    epcf90... no
    gfortran... no
    g95... no
    xlf95... no
    f95... no
    fort... no
    ifort... no
    ifc... no
    efc... no
    pgf95... no
    lf95... no
    ftn... no
    shl_load... no
    shl_load in -ldld... no
    dlopen... no
    swig... no
    python/Python.h usability... no
    python/Python.h presence... no
    python/Python.h... no
    /usr/lib/j2sdk1.5-sun/include/jni.h... no
    /usr/lib/j2sdk1.5-sun/include/linux/jni_md.h... no
    javac... no
    gsl/gsl_version.h usability... no
    gsl/gsl_version.h presence... no
    gsl/gsl_version.h... no
    Device.h... no
    ARTOOLKITPLUS... no
    main in -lraw1394... no
    dc1394/control.h usability... no
    dc1394/control.h presence... no
    dc1394/control.h... no
    libraw1394/raw1394.h usability... no
    libraw1394/raw1394.h presence... no
    libraw1394/raw1394.h... no
    libdc1394/dc1394_control.h usability... no
    libdc1394/dc1394_control.h presence... no
    libdc1394/dc1394_control.h... no
    jpeglib.h usability... no
    jpeglib.h presence... no
    jpeglib.h... no
    linux/videodev2.h... no
    linux/videodev.h usability... no
    linux/videodev.h presence... no
    linux/videodev.h... no
    asm/ioctls.h usability... no
    asm/ioctls.h presence... no
    asm/ioctls.h... no
    OPENCV... no
    isense/isense.h usability... no
    isense/isense.h presence... no
    isense/isense.h... no
    linux/joystick.h usability... no
    linux/joystick.h presence... no
    linux/joystick.h... no
    linux/wireless.h... no
    GDK_PIXBUF... no
    GDK_PIXBUF... no
    MRICP... no
    usb.h usability... no
    usb.h presence... no
    usb.h... no
    phidget21.h usability... no
    phidget21.h presence... no
    phidget21.h... no
    phidget21.h... (cached) no
    geos_c.h usability... no
    geos_c.h presence... no
    geos_c.h... no
    libparticle.h usability... no
    libparticle.h presence... no
    libparticle.h... no
    robotinocom.h usability... no
    robotinocom.h presence... no
    robotinocom.h... no
    xtimer.h usability... no
    xtimer.h presence... no
    xtimer.h... no
    xthread.h usability... no
    xthread.h presence... no
    xthread.h... no
    OPENCV... no
    linux/serial.h usability... no
    linux/serial.h presence... no
    linux/serial.h... no
    linux/serial.h... (cached) no
    linux/serial.h... (cached) no
    OPENCV... no
    linux/videodev.h... (cached) no
    libusbSR.h usability... no
    libusbSR.h presence... no
    libusbSR.h... no
    STATGRAB... no
    OPENCV... no
    linux/serial.h... (cached) no
    geos_c.h... (cached) no
    linux/serial.h... (cached) no
    yarp/os/all.h usability... no
    yarp/os/all.h presence... no
    yarp/os/all.h... no
    yarp/sig/all.h usability... no
    yarp/sig/all.h presence... no
    yarp/sig/all.h... no
    openssl/md5.h usability... no
    openssl/md5.h presence... no
    openssl/md5.h... no
    MD5_Init in -lcrypto... no
    GNOMECANVAS... no
    GTK... no
    GDK_PIXBUF... no
    main in -lboost_signals... no
    main in -lboost_signals-gcc-mt... no
    main in -lboost_thread... no
    main in -lboost_thread-mt... no
    main in -lboost_thread-gcc-mt... no
    sys/soundcard.h usability... no
    sys/soundcard.h presence... no
    sys/soundcard.h... no
    sys/filio.h usability... no
    sys/filio.h presence... no
    sys/filio.h... no
    linux/joystick.h... (cached) no
    jpeglib.h... (cached) no
    zlib.h usability... no
    zlib.h presence... no
    zlib.h... no
    compress2 in -lz... no
    xdrmem_create in -lrpc... no
    compressBound... no
    GEOSGeomFromWKB_buf in -lgeos_c... no
    if socklen_t is defined... no
    if O_SYNC is defined... no
    poll... no
    dirname... no
    cfmakeraw... no
    round... no
    sigblock... no
    getaddrinfo... no
    gethostbyname in -lnsl... no
    connect in -lsocket... no
    nanosleep in -lrt... no
    clock_gettime... no
    lt_dlopenext in -lltdl... no
    pthread_create in -lc_r... no
    jpeg_read_header in -ljpeg... no
    glBegin in -lGL... no
    main in -lGLU... no
    main in -lglut... no
    OPENCV... no
    IMAGEMAGICK... no
    GSL... no
    xmms-config... no

    Sorry if it was too messy, Thankyou all.

    Best Regards,
    Abqorian

  2. #2
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    All of those packages may not be necessary for installation. Many times, the dependency check also provides Required dependencies at the end before showing that install failed. Sometimes the list is incomplete due to pre-requisites. First, go to Easy Urpmi
    and add PLF media. I will try to post the package names as listed in MCC from Mandriva when I can, or maybe someone else can help too. Loy.

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    8
    Quote Originally Posted by Loy Glenn View Post
    All of those packages may not be necessary for installation. Many times, the dependency check also provides Required dependencies at the end before showing that install failed. Sometimes the list is incomplete due to pre-requisites. First, go to Easy Urpmi
    and add PLF media. I will try to post the package names as listed in MCC from Mandriva when I can, or maybe someone else can help too. Loy.
    Well, thank you first of all. I was compiling P/S from the source, since that was the only package available for download. I tried to install them from the rpmdrake,but that was wastin time since the package it self not available. I've been in Easy Urpmi, but havent try the PLF media. Well, thanks anyway, I'll try it.

  4. #4
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Before I begin to give you a complete list of package names, do you know how to use the Software Installer? Try issuing the command "rpmdrake" from a console. When using this utility, all dependencies will be installed w/ the selected package. (too bad Player&Stage isn't in any repo.) Begin by installing gcc, make, java-1.6.0-sun,java-1.6.0-sun-devel,gtk+2.0,libgnomecanvas2_0,libgnomecanvas2_0-devel,and python. (those are the package names) Now try running the configure command again and post unsatisfied dependencies if you can't find them by searching in rpmdrake. Loy.

    ::edit-rpmdrake should install all dependencies required when installing from repo. As we all know sh*t happens, but at least it's not MS. I happen to love Mandi - prior to '09 w/ kde 4.1::
    Last edited by Loy Glenn; 01-10-2009 at 09:09 PM. Reason: not all

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    8
    Thank you again.
    All of the major (main) dependencies have been installed (like gcc and other common package) but as I posted before, most of the dependencies were not available in the repo. My friend told me that Ubuntu works fine with that, it can install the dependencies, so maybe it has them in its repo.

  6. #6
    Just Joined!
    Join Date
    Jan 2009
    Posts
    8
    Hello.
    I've added PLF media into my repo.
    I've installed and some upgraded these packages (only).
    These are the packages I found after refreshing the repo and install (and upgrade) them:

    g77 (gcc for gfortran)
    gsl
    sed
    libraw1394
    libjpeg and jpegtool (upgrade also)
    opencv
    update libusb
    statgrab
    libgeos
    openssl lib
    libgnomecanvas
    lib for imagemagick
    boost (don't know if this is the one)
    roundup (don't know if this is the one)
    swig

    Then do the ./configure again, but the error persist. And the package that was already installed still appear as "....no".
    I don't know, but it's as if the configure didn't know that some packages have already been installed.

    And the rpmdrake seems error with this message:
    "/usr/bin/perl: symbol lookup error: /usr/lib/libpangocairo-1.0.so.0: undefined symbol: cairo_has_current_point"

    I couldn't use the rpmdrake anymore. What should I do?

  7. #7
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Many packages have a "Devel" set as well. When required as a dependency to build another package, this is the part that is used. So even if you have the base package installed, you will probably need to install the Devel section of the package as well. (Basically look for this "-devel" at the end of the package name and install.)

    Maybe this will help with the rpmdrake error...
    in a root console type:

    urpmi --clean

    urpmi.update -a

    urpmi --update --auto --auto-select --no-install -noclean

  8. #8
    Just Joined!
    Join Date
    Jan 2009
    Posts
    8
    1. Did the ./configure returned: exit 0

      I knew it from the config.log
      eventhough some packages still returned as "no".


    1. Did the make install, returned:

      Making install in replace
      make[1]: Entering directory `/home/abe/player-2.1.1/replace'
      /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I../libplayercore -I../client_libs/libplayerc++ -I../client_libs/libplayerc -g -O2 -MT poll.lo -MD -MP -MF .deps/poll.Tpo -c -o poll.lo poll.c
      gcc -DHAVE_CONFIG_H -I. -I.. -I../libplayercore -I../client_libs/libplayerc++ -I../client_libs/libplayerc -g -O2 -MT poll.lo -MD -MP -MF .deps/poll.Tpo -c poll.c -fPIC -DPIC -o .libs/poll.o
      In file included from poll.c:26:
      replace.h:100: warning: ‘struct timespec’ declared inside parameter list
      replace.h:100: warning: its scope is only this definition or declaration, which is probably not what you want
      In file included from poll.c:34:
      /usr/include/unistd.h:245: error: two or more data types in declaration specifiers
      poll.c: In function ‘poll’:
      poll.c:79: warning: incompatible implicit declaration of built-in function ‘alloca’
      make[1]: *** [poll.lo] Error 1
      make[1]: Leaving directory `/home/abe/player-2.1.1/replace'
      make: *** [install-recursive] Error 1

      what was this mean?
      what's the problem?


    1. did what you suggest for rpmdrake, returned this:

      Xlib: connection to ":0.0" refused by server
      Xlib: No protocol specified

      Cannot be run in console mode.
      And by the way the option " -noclean " wasn't recognized.


    Thank you

  9. #9
    Just Joined!
    Join Date
    Jan 2009
    Posts
    8
    can't add any packages because of the error in the rpmdrake. seems like all other apps that use perl are affected. Any app which try 'to open new window' such as save as will be crash and closed.

    So was the "Control Panel" and "Configure your computer". What's the command for these two?

  10. #10
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Try "mcc" to get into the Mandriva Control Center...
    "rpmdrake" to go directly to add/remove programs...Will help more as soon as time allows, don't give up, Loy.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •