Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 33
Easy way ... download those files to your desktop. right click each one, extract to /xxx. open konsole. cd $HOME/dekstop/xxx ./configure then ./make finally as root ./make install the order ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89

    Easy way ...

    download those files to your desktop.
    right click each one, extract to /xxx.
    open konsole.
    cd $HOME/dekstop/xxx
    ./configure
    then
    ./make
    finally as root
    ./make install

    the order for this install is
    1.alsa driver pkg.
    2.alsa lib pkg.
    3.alsa util pkg.
    as for the others, I believe if the 1st 3 are installed, there is no specific order required...

  2. #22
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    I hate to be a noob, but I seem to have a problem with my C compiler.
    Code:
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.
    If you want the config log tell me and I'll attach it, it's like 600 lines.
    Thanks
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  3. #23
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    From Konsole type rpmdrake
    Be sure both drop down menus say "all"
    in the search box type gcc
    install
    gcc (4.2.3)
    gcc-c++ (4.2.3)
    gcc-cpp (4.2.3)
    then search for "make" and install
    make (3.81)

    the versions don't have to be the same, just try to install the latest version.

  4. $spacer_open
    $spacer_close
  5. #24
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Thanks.
    Now I have a new problem:

    Code:
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for ranlib... ranlib
    checking for a BSD-compatible install... /usr/bin/install -c
    checking how to run the C preprocessor... gcc -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for an ANSI C-conforming const... yes
    checking for inline... inline
    checking whether time.h and sys/time.h may both be included... yes
    checking whether gcc needs -traditional... no
    checking for current directory... /home/mord/Desktop/Alsa/alsa-driver-1.0.19
    checking cross compile...
    checking for directory with kernel source... ./configure: line 4820: cd: /usr/src/linux: No such file or directory
    /usr/src/linux
    checking for directory with kernel build...
    checking for kernel linux/version.h... no
    The file /include/linux/version.h does not exist.
    Please install the package with full kernel sources for your distribution
    or use --with-kernel=dir option to specify another directory with kernel
    sources (default is /usr/src/linux).
    What does that mean?
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  6. #25
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Run urpmi
    on the righ drop down menu select installed
    search for kernel
    note which "kernel-xx" packages are installed on your sys.
    change the drop down to all
    search kernel
    find the "kernel-xx-deve"l packages and install.
    Also be sure "kernel-headerxx" package is installed

    If you get the same error install the corresponding "kernel-sourcexxx" packages....repost if you need more help.

  7. #26
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    out of curiosity is this an alsa mixer or a hardware issue cause as far as i know when you plug in headphones the physical connection for sound to the speakers is disconnected physically . the question is do you have any other operating systems on your pc do the headphones work there . i have mandriva 2008 and 2009 there is no option for headphone sound but when i plug in headphones speaker sound is automatically disconnected

  8. #27
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Definitely not a hardware issue.
    As of now, Mandriva is the only operating system on my computer. I used to run Vista, at first by itself, and then in tandem with Mandriva, but it wasn't worth it. Anyway, when using Vista, as soon as I'd plug in the headphones, the speakers would turn off.
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  9. #28
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    ok then have you tried running alsaconf the alsa configuration tool

  10. #29
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    When I type alsaconf I get command not found
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  11. #30
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    out of curiosity is this an alsa mixer or a hardware issue cause as far as i know when you plug in headphones the physical connection for sound to the speakers is disconnected physically . the question is do you have any other operating systems on your pc do the headphones work there . i have mandriva 2008 and 2009 there is no option for headphone sound but when i plug in headphones speaker sound is automatically disconnected
    THis chipset (I believe) is controlled at the software (driver) level for the hadphone/speaker switch, it is not a hardware circuit that acts as the switch. I have noticed MANY complaining of this very issue, and the bug is not limited to a specific OS.

    All I know to do is upgrade to the latest ALSA versions, and maybe say a prayer , as I have not seen a definite solution to this posted anywhere. Installing all of the ALSA stuff from the links I posted should eliminate the "command not found" error. Then maybe someone else may be able to help more than I can.

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •