Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 33
I have a Toshiba laptop, and am running Mandriva 2008.1 KDE 3.5 When I plug in my headphones, I would like for the speakers to stop working, but they don't. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197

    [SOLVED] Headphones and speakers


    I have a Toshiba laptop, and am running Mandriva 2008.1 KDE 3.5
    When I plug in my headphones, I would like for the speakers to stop working, but they don't.
    What should I do?

    <Edit>
    My sound card is Intel Corporation|82801G (ICH7 Family) High Definition Audio Controller.
    The driver I am using is ALSA "snd_hda_intel".
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  2. #2
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Do you have acpi and apic features enabled?

  3. #3
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Um, what's that?
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    ACPI - Advanced Configuration and Power Interface.
    Advanced Configuration and Power Interface - Wikipedia, the free encyclopedia

    APIC - Advanced Programmable Interrupt Controller.
    Intel APIC Architecture - Wikipedia, the free encyclopedia


    I ask because these may affect the integrated sound card functions, (the switches are software controlled now). Open mcc, go to boot, then setup boot system. Under main options is ACPI, and beneath advanced is APIC. If that fails to help, try using a different driver for the card (maybe OSS?). Apparently, there are many such issues w/ laptops on Linux and windoze...Loy

  6. #5
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Open mcc, go to boot, then setup boot system. Under main options is ACPI, and beneath advanced is APIC
    Both are enabled.
    If that fails to help, try using a different driver for the card (maybe OSS?)
    Well, I can't find that driver, and there are hundreds I can choose from....
    Any other ideas?
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  7. #6
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Open mcc, goto hardware, sound configuration, and next to driver there should be a drop down menu of drivers currently available for your card...Loy.

  8. #7
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Yes, I did that, there are hundreds of drivers there. How do I know which to use?
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  9. #8
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Do you see one begining w/ OSS?

  10. #9
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Nope, no OSS.
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

  11. #10
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Ok, make sure that the driver currently used is an ALSA drive corresponding to your soundcard (or at least the chipset for it). Open mcc, goto hardware then sound configuration. Turn OFF pulse audio support (should include auto. routing from.....) restart your session. Open the mixer and see if you have separate audio controls for headphones and speakers...Loy.

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •