Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, I cannot seem to install the 64 bit version of Mandriva 2009.0. I am running an ALive FN4G-DVI motherboard with AMD Sempron 3000 processor. I have 2GB RAM on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Location
    Sheffield, England
    Posts
    45

    [SOLVED] 64 bit install gives no video


    Hello, I cannot seem to install the 64 bit version of Mandriva 2009.0. I am running an ALive FN4G-DVI motherboard with AMD Sempron 3000 processor. I have 2GB RAM on dual channel access. I have 3 x 80GB IDE hard drives. I have also tried this install on a 160GB SATA drive with the same result. The installation goes all the way to perfection except after you get the install CD out and reboot, there is no video. It goes all the way to where it starts resolv.conf, which is where the screen goes black, you get the "no signal" window which quickly goes away. The screen shows that it is getting a signal. You can see the mouse cursor and move it around but there is no picture. I have 64 bit versions of 2006 official and 2007 official. I have tried to install them and then upgrade to 2009 but it will not do it. I have tried to upgrade a 32 bit install but it won't do that either. Does someone know what is going on and is there a fix? Thanks.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which Graphics Card do you have? Does pressing Alt+Ctrl+F1 switch to Command Line mode?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Location
    Sheffield, England
    Posts
    45

    Graphics

    Hi, the graphics is onboard on the motherboard and is nVidia GeForce 6100, wIth 128 MB ram allocated. As to the ctrl alt F1, I have never tried it.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Its a Graphics Card problem only. Press Alt+Ctrl+F1 and check if it drops you at command line prompt.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2

    Smile It should be a generic problem

    I found the following from Mandriva 2009 Wiki. The 2nd method worked for me.

    ****
    Several users have reported that One editions of Mandriva Linux 2009 fail to create the file /etc/X11/xorg.conf when booting.

    This can then result in several possible scenarios. What happens is X.org will attempt to automatically detect the card and load the appropriate driver. If you are lucky, this will work, and you will likely never notice the problem.

    If X.org auto-configuration fails entirely, this results in the graphical desktop failing to start. In this case, One will boot to a text login screen.

    In the worst case, X.org auto-configuration finds a valid driver but it fails to work due to conflicts with the framebuffer system, resulting in an apparent failed boot: a blank screen with a cursor flashing at the top-left hand corner. There are two approaches if you find yourself in this situation.

    You can reboot and use the text mode, rather than graphical, boot - this option is available from the One boot screen after pressing F3. This should result in a successful graphical boot, although the most optimal driver for your hardware is most likely not being used. You can then run the graphics card configuration tool from the Mandriva Control Center to generate the /etc/X11/xorg.conf file, if you wish; you should do this if you intend to install One permanently. If you do this and then install One to your hard disk, the issue should not recur when booting the installed system.

    Alternatively, when you see the blank screen, press Alt+F2 to get to a text login screen. You can then log in as user root (no password) and run drakx11. Accept all the default settings in this tool, and then close it. Then run the command service -f dm, and the graphical desktop should start up correctly. If you then install One to hard disk, the issue should not recur when booting the installed system. However, it will recur each time you boot live from the One CD.

    *****

    Hop this wud help

  6. #6
    Just Joined!
    Join Date
    Aug 2006
    Location
    Sheffield, England
    Posts
    45

    thanks

    Brilliant response. I am installing Mandy 2009.0. I will be doing installs Sunday/Monday and you have both given me hope and a plan of attack so that, maybe, I can get there. I will let you know the results. If the 64 bit fails after that it looks like I am stuck with 32 bit processing. Thank you so much for your help so far.

  7. #7
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2

    Wink .....

    Ys pls get bak aftr tryin....

    I had a GeForce 6200TC on a nForce4 Ultra chip. I was tryin 2 install Man2009 32-bit KDE ver.

    Wen running the drakx tool jus select your Vid card & native display resolution... Things shud jus wrk fine....

  8. #8
    Just Joined!
    Join Date
    Aug 2006
    Location
    Sheffield, England
    Posts
    45

    no good

    OK fellas, did a full install from scratch and the same result. It is running nVidia GeForce 6100 using the native X driver nv. It sees the screen as HannsG H191Q which is correct. It sets the display as automatic. I changed that to 1280 x 1024 with 16 million colours. This time it really tried harder to display but it failed. I did the ctrl - alt - F1 and logged on as root. I went through the drakx routine, ran service -f dm and WE GOT THERE, I got the screen! I then rebooted to see what I got and YES, ALL IS WELL! Finally, I can have a 64 bit PC and the back up PC on 32 bit. Thank you both for all your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •