Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I just installed Mandrake 10.0 last week and have been getting to grips with it and have been useing KDE. I though I would try to install a program ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    20

    Noob needs help installing glame


    Hi,

    I just installed Mandrake 10.0 last week and have been getting to grips with it and have been useing KDE.

    I though I would try to install a program form source to see how its done etc. I decided to give glame a try (from glame-1.0.2.tar.gz) I unpacked it and tried the usual ./configure glame came up withthe following error:

    configure: error: You need gnome to compile the graphical user interface.
    Hint: you also need the appropriate development packages for gnome installed,
    usually called gnome-dev, libgnome-dev or similar. You can disable the
    graphical user interface by providing the --disable-gui switch to the
    configure script.

    I wanted the GUI so i went on the internet and found
    gnome-libs_1.4.2.orig.tar.gz. When I tried to install this it said that I needed GTK - 1.2.0, so i downloded gtk+-2.4.0.tar.gz after a while I managed to get GTK installed, I think, but when I try to install the Gnome libs it still says it cant find gtk-config and told me to set GTK_CONFIG enviroment to full path to gtk-config. I cannot find gtk-config any where after many internet searches and trying everything i could find still nothing.

    So, I am totally stuck now.
    I am confused as I have Gnome installed as well as KDE, does that not mean I have the correct libaries to install Glame?
    Could some one please point mein the right direction (or better yet show me exactly what to do)

    I really want to under stand Linux and be able to free myself from Windoze for good.

    Any help is greatly apreciated.

    Martyn...

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    whereis gtk-config
    then take the path found by whereis and do
    Code:
    GTK_CONFIG=/path/to/gtk/config
    export GTK_CONFIG
    then try again

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    20
    Thanks for the quick reply.

    I tried whereis gtk-config and is just returned
    gtk-config:

    does that mean I havent installed it correctly?

    Its GTK+ 2.4.0 that I have installed but the Gnome libs ask for GTK - 1.2.0 should this still work? does the + and - make any diffrence?

    Am I even trying to install the correct thing as far as the Gnome libs go that Glame says it needs?

    Martyn...

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    20

    New Problem.

    Ok I have got the GTK problem sorted out (I was using too new a version of GTK)

    Now when I try to ./compile gnome-libs_1.4.2.orig.tar.gz source it says that i dont have ORBit installed, I found that I had an ORBit RPM on my Mandrake 10.0 CD (Sorry I dont know what version) but when I try to install it I'm told that it is already installed??

    What am I doing wrong? Pls Help a poor newbie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •