Find the answer to your Linux question:
Results 1 to 3 of 3
I have Mandriva Linux 2009 PowerPack on a ASUS eeePC 1000HE which i installed about 2 weeks ago. I am using the KDE 3.5 desktop and the system has 2GB ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    93

    Mandriva saying temp directory out of space


    I have Mandriva Linux 2009 PowerPack on a ASUS eeePC 1000HE which i installed about 2 weeks ago. I am using the KDE 3.5 desktop and the system has 2GB Memory, 160GB Hard Drive space. As far as I remember I used all default install options when I installed.

    Tonight i tried to install some system updated but shortly after it started it gave errors that there was not enough space. I then tried to reboot and it said "Temp directory /tmp) is out of disk space. KDE is unable to start.

    I know with linux there are 3 partitions, swap, and something like a partition for programs and data. Would this have to do anything with it? Or is there a temp directory somewhere that ran out of space. How do i fix this issue? I am new to Linux so don't know a lot and can't even boot into this system now. How would I fix a problem like this?

  2. #2
    Just Joined!
    Join Date
    Apr 2009
    Posts
    90
    Firstly, on the command line do a "df -h", this will show you all of the free disk space for all of the configured mount points.

    for instance, on mine it shows:

    Filesystem Size Used Avail Use% Mounted on
    /dev/mapper/System-Root
    40G 4.9G 36G 13% /
    udev 499M 264K 498M 1% /dev
    /dev/sda1 479M 17M 438M 4% /boot
    tmpfs 499M 12K 499M 1% /tmp
    /dev/mapper/cr_Home 146G 98G 41G 71% /home


    as you can see, I have something called "tmpfs" mounted on /tmp. This is just a ramdisk of sorts - that I find suits me very well - it is cleared automatically at reboot. If you want to add it, just add the following line to your /etc/fstab file

    tmpfs /tmp tmpfs noatime 0 0

    Otherwise, just check to see what partition /tmp is on, and perhaps think about freeing up some space?

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35
    I too have had the same problem of Temp file being out of space. It turned out that the hda5 partition which holds the temp file was actually full. I had at installation copied all the Mandriva DVD onto my HD to ease installing new apps.

    I increased the size of my hda5 and removed the DVD files.

    The result is shown in the following :
    Filesystem Size Used Avail Use% Mounted on
    /dev/hda5 10G 3,8G 5,8G 40% /
    /dev/hda7 74G 27G 47G 37% /home
    /dev/hda1 23G 13G 9,6G 58% /mnt/window s

    Increasing space on hda5 has solved/removed the problem.

    Hope that helps,

    Tony Littlejohn

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •