Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I have a strange problem. I installed Mandriva 2009 Spring yesterday. Its wonderful. Everything worked fine. But today when I booted, its autologging me! There was no such ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305

    unable to disable autologin


    Hi all,
    I have a strange problem. I installed Mandriva 2009 Spring yesterday. Its wonderful. Everything worked fine. But today when I booted, its autologging me! There was no such issues yesterday!

    Apparently, I have not done anything to enable autologin. I just browsed net, configured my mail client, installed 2-3 packages with urpmi...thats all. Didn't even touch computer/desktop management module. How did it automatically got enabled today?

    The other strange thing is if I go to System Settings -> Advanced -> Login Manager, all options are greyed out. There is no button to go to Adminstrator Mode! Ref. attachment.

    Further I tried to search for kdm in /etc. Didn't find one there. Then got hold of kdm in /usr/share. Here kdm is present in two places, /usr/share/apps and /usr/share/config. I went to /usr/share/config/kdm/kdmrc and checked if anything related to AutoLogin is enabled. No, its not enabled there.

    Then I found one /etc/sysconfig/autologin. In this file AUTOLOGIN=yes is the entry. I edited this (as root, ofcourse) as AUTOLOGIN=no, saved and rebooted. Guess what, its still autologging and when I opened the file its still AUTOLOGIN=yes! Something is overwriting this file. Whats happening? Is this a virus? I dont use any p2p clilents, I don't install much softwares apart from irssi, ttf-indic-fonts, thunderbird and gstreamer/xine codecs in any distro I try.

    I can't login to GUI as root and there is no Administrator Mode in Login Manager. I can't find a correct file to edit to solve this autologin problem.

    I tried in #mandriva, in mandriva forums, searched google and here in this forum too. Its mostly to use Login Manager to go to Administrator Mode and then check or uncheck autologin option. This is not working in my case.

    How come there is no Administrator Mode button in Login Manager? And why /etc/sysconfig/autologin file is getting overwritten to 'yes'? Please can somebody help me? Apart from this Mandriva rocks!
    Attached Images Attached Images
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  2. #2
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305

    Problem proper solved, doubts remain!

    Ok, here is the update for those interested.

    I had not gone through /usr/share/config/kdm/kdmrc properly. It ended like the following:
    Code:
    # Greeter config for 1st local display
    AutoLoginEnable=true
    AutoLoginUser=saivin
    [X-:0-Greeter]
    First time when I read the file I had only gone through the following:
    Code:
    # Enable automatic login. USE WITH EXTREME CARE!
    # Default is false
    #AutoLoginEnable=true
    # If true, auto-login after logout. If false, auto-login is performed only
    # when a display session starts up.
    # Default is false
    #AutoLoginAgain=true
    As the Autologin was commented out, I thought kdmrc file was ok and it had nothing to do with my autologin. When I went through the file again, I realized Autologin was indeed enabled and then disabled it. Now its working fine. The /etc/sysconfig/autologin is still 'AUTOLOGIN=yes' but apparently it is overrided by kdmrc file.

    As for as my autologin problem was concerned, it is solved. But I still have unanswered questions.
    a) How did all of a sudden autologin got enabled?
    b) Why there is no Administrative Mode in Login Manager?
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  3. #3
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305

    Thumbs up Issues solved

    Ok, one more update...

    I found which GUI tool to use if Login Manager fails. Its in 'Configure Your Computer' (not 'Configure Your Desktop' where the 'Login Manager' is present).

    Configure Your Computer -> Boot -> Set up autologin to automatically log in (under Configure boot steps).

    Now, as this configuration tool requires root privilages (which is Mandriva specific), Mandriva might have removed Administrator Mode from Login Manager. This probably answers my second question.

    For the first question as to how autologin got enabled all of a sudden, may be I might have unwittingly enabled it here, in 'Configure Your Computer' control center! I had visited Mandriva Control Center to check my wireless setup. :P

    Anyway, my issues are solved. Have to learn package management (at console level, I mean).

    Ah, at last I think I have found my desktop distro...! Mandriva rocks!!!
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  4. #4
    Linux Newbie Max2009's Avatar
    Join Date
    Nov 2008
    Posts
    197
    Quote Originally Posted by saivin View Post
    Ok, one more update...
    For the first question as to how autologin got enabled all of a sudden, may be I might have unwittingly enabled it here, in 'Configure Your Computer' control center! I had visited Mandriva Control Center to check my wireless setup. :P
    No, you didn't. The same thing happened to me. It just automatically set the auto login without any prompting. Now I know how to fix it.
    Thanks.
    Mandriva rocks!!!
    Yes it does.
    Cogito ergo surf - I think therefore I network.

    Registered Linux user #481826 Get counted!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •