Find the answer to your Linux question:
Results 1 to 6 of 6
1:§ Ok I'm trying to figure out how to install Ethernet 10/100 and Realtek drivers into Mandriva Discovery. I have located the .tar.gz files but I cannot get any results. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Nurolized's Avatar
    Join Date
    Jun 2008
    Posts
    8

    Lightbulb [SOLVED] Install help for novice


    1:§ Ok I'm trying to figure out how to install Ethernet 10/100 and Realtek drivers into Mandriva Discovery. I have located the .tar.gz files but I cannot get any results. Commands like make, make install, .config, modprobe, insmod and others from the readme instructions do not work. I can't find RPMs for these drivers either and just found out I need to install gcc g++ binutil and others, or so I think. Could someone share the process of installing .tar.gs files or point me to resources of info specific to Mandriva.

    Also I want to ask, If you fudge up and install using terminal commands will Linux automatically delete files folders that were attempted to be apart of the install or will I just have junk floating around the system tree.

    I'm really back to basics here....But I did manage to dual boot Discovery and XP so all hope is not lost!

    Thanks»»»

  2. #2
    Just Joined!
    Join Date
    Mar 2009
    Posts
    14
    Nurolized:

    Those drivers usually are detected and installed by default, if you're not sure just go to Mandriva Control Center and setup your ethernet and audio there. As for your attempt to compile the stuff if you're not sure it worked or not just go to that folder and as a "user" do a "make clean" and as "root" do a "make uninstall". Just make sure those are the programs you tried to install or you'll really mess up things.

    MaRk-I

  3. #3
    Just Joined! Nurolized's Avatar
    Join Date
    Jun 2008
    Posts
    8
    these drivers arn't available in the control center, In harware most of my stuff is(null) I'm wondering if I should update the kernel to fix this. I have no sound and no ethernet axcess. I have been trying to install drivers that I have found in .tar.gz but I get Kernal source not found, curses lib, libsound2 and when I run install in terminal I cant determine if the thing has been installed or not. modprobe and eth0 up does nothing and my sound card install resulted in this......

    [nurhenion@localhost networkvideo]$ su
    Password:
    [root@localhost networkvideo]# sudo ./install.sh
    e1000-7.6.5/
    e1000-7.6.5/src/
    e1000-7.6.5/src/Makefile
    e1000-7.6.5/src/e1000.h
    e1000-7.6.5/src/e1000_80003es2lan.c
    e1000-7.6.5/src/e1000_80003es2lan.h
    e1000-7.6.5/src/e1000_82540.c
    e1000-7.6.5/src/e1000_82541.c
    e1000-7.6.5/src/e1000_82541.h
    e1000-7.6.5/src/e1000_82542.c
    e1000-7.6.5/src/e1000_82543.c
    e1000-7.6.5/src/e1000_82543.h
    e1000-7.6.5/src/e1000_82571.c
    e1000-7.6.5/src/e1000_82571.h
    e1000-7.6.5/src/e1000_api.c
    e1000-7.6.5/src/e1000_api.h
    e1000-7.6.5/src/e1000_defines.h
    e1000-7.6.5/src/e1000_ethtool.c
    e1000-7.6.5/src/e1000_hw.h
    e1000-7.6.5/src/e1000_ich8lan.c
    e1000-7.6.5/src/e1000_ich8lan.h
    e1000-7.6.5/src/e1000_mac.c
    e1000-7.6.5/src/e1000_mac.h
    e1000-7.6.5/src/e1000_main.c
    e1000-7.6.5/src/e1000_manage.c
    e1000-7.6.5/src/e1000_manage.h
    e1000-7.6.5/src/e1000_nvm.c
    e1000-7.6.5/src/e1000_nvm.h
    e1000-7.6.5/src/e1000_osdep.h
    e1000-7.6.5/src/e1000_param.c
    e1000-7.6.5/src/e1000_phy.c
    e1000-7.6.5/src/e1000_phy.h
    e1000-7.6.5/src/e1000_regs.h
    e1000-7.6.5/src/kcompat.c
    e1000-7.6.5/src/kcompat.h
    e1000-7.6.5/src/kcompat_ethtool.c
    e1000-7.6.5/COPYING
    e1000-7.6.5/README
    e1000-7.6.5/ldistrib.txt
    e1000-7.6.5/pci.updates
    e1000-7.6.5/e1000.spec
    e1000-7.6.5/e1000.7
    e1000-7.6.5/SUMS
    make -C /lib/modules/2.6.17-5mdv/build SUBDIRS=/home/nurhenion/Download/networkvideo/e1000-7.6.5/src modules
    make[1]: Entering directory `/usr/src/linux-2.6.17-5mdv'

    WARNING: Symbol version dump /usr/src/linux-2.6.17-5mdv/Module.symvers
    is missing; modules will have no dependencies and modversions.

    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_main.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_82540.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_82542.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_82571.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_82541.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_82543.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_ich8lan.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_80003es2lan.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_mac.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_nvm.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_phy.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_manage.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_param.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_ethtool.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/kcompat.o
    CC [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000_api.o
    LD [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000.o
    Building modules, stage 2.
    MODPOST
    CC /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000.mod.o
    LD [M] /home/nurhenion/Download/networkvideo/e1000-7.6.5/src/e1000.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.17-5mdv'
    gzip -c ../e1000.7 > e1000.7.gz
    # remove all old versions of the driver
    find /lib/modules/2.6.17-5mdv -name e1000.ko -exec rm -f {} \; || true
    find /lib/modules/2.6.17-5mdv -name e1000.ko.gz -exec rm -f {} \; || true
    install -D -m 644 e1000.ko /lib/modules/2.6.17-5mdv/kernel/drivers/net/e1000/e1000.ko
    /sbin/depmod -a || true
    install -D -m 644 e1000.7.gz /usr/share/man/man7/e1000.7.gz
    man -c -P'cat > /dev/null' e1000 || true
    Verifying archive integrity... OK
    .................................................. .................................................. .................................................. .................................................. .................................................. ...........................
    [root@localhost networkvideo]# insmod e1000
    insmod: can't read 'e1000': No such file or directory
    [root@localhost networkvideo]#


    what do i have to do to get the e1000 to work????????

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2009
    Posts
    14
    to install your kernel sources they have to match your current kernel so type: uname -ar you'll get an output with your current kernel go to the package installer and find kernel-sources with your same version and install. Looking @ your output I see "2.6.17-5mdv" if that's the same just find the kernel sources for that version. also once finished type:

    insmod /lib/modules/2.6.17-5mdv/kernel/drivers/net/e1000/e1000.ko

    see if that works... good luck.

  6. #5
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    MaRk-I is right... these drivers should be installed already. Is your NIC being detected?
    What is the output of
    Code:
    lspci | grep Ethernet
    ifconfig -a
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  7. #6
    Just Joined! Nurolized's Avatar
    Join Date
    Jun 2008
    Posts
    8

    E1000 install

    Thanks MaRK-I, I ran the command as you said and I do get eth0 in network monitoring however I cannot connect to internet, It tells me to check configurations and I tried entering Dhcp Ip address and Gateway but still nothing, I do have a lot of Pci bridges and stuff that are not recognized in hardware manager (null) all intel stuff. when I do install manually it bings up "module symvers". I have been searching online for e1000 connection tips and I will try jayd512 suggestion tomorrow. modprobe e1000 and ifconfig e1000 does nothing i can tell. I've been checking oreillynet.com/linux/cmd/ for command ideas and gaining knowledge. Thanks

    Here is the results of jayd512 suggestion»»lspci | grep Ethernet
    00:19.0 Ethernet controller: Intel Corporation Unknown device 10c0 (rev 02)
    [nurhenion@ ~]$ ifconfig -a
    bash: ifconfig: command not found
    [nurhenion@ ~]$

    ----------------------------------------------------------
    my pci scan»»pci
    [nurhenion@00-1D-09-90-ED-9F ~]$ lspci
    00:00.0 Host bridge: Intel Corporation Unknown device 29c0 (rev 02)
    00:01.0 PCI bridge: Intel Corporation Unknown device 29c1 (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation Unknown device 29c2 (rev 02)
    00:19.0 Ethernet controller: Intel Corporation Unknown device 10c0 (rev 02)
    00:1a.0 USB Controller: Intel Corporation Unknown device 2937 (rev 02)
    00:1a.1 USB Controller: Intel Corporation Unknown device 2938 (rev 02)
    00:1a.2 USB Controller: Intel Corporation Unknown device 2939 (rev 02)
    00:1a.7 USB Controller: Intel Corporation Unknown device 293c (rev 02)
    00:1b.0 Audio device: Intel Corporation Unknown device 293e (rev 02)
    00:1d.0 USB Controller: Intel Corporation Unknown device 2934 (rev 02)
    00:1d.1 USB Controller: Intel Corporation Unknown device 2935 (rev 02)
    00:1d.2 USB Controller: Intel Corporation Unknown device 2936 (rev 02)
    00:1d.7 USB Controller: Intel Corporation Unknown device 293a (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
    00:1f.0 ISA bridge: Intel Corporation Unknown device 2916 (rev 02)
    00:1f.2 RAID bus controller: Intel Corporation SATA Controller RAID (rev 02)
    00:1f.3 SMBus: Intel Corporation Unknown device 2930 (rev 02)
    02:00.0 Communication controller: Conexant HSF 56k Data/Fax Modem
    Last edited by Nurolized; 05-21-2009 at 04:37 AM. Reason: UPDATE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •