Find the answer to your Linux question:
Results 1 to 5 of 5
I've just installed Mandriva (2009.1 KDE4) on my PC but don't see the xgl/compiz effects ie "wobbly windows" etc. How do I turn these things on ? I'm ok at ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    11

    New user wants to see xgl effects


    I've just installed Mandriva (2009.1 KDE4) on my PC but don't see the xgl/compiz effects ie "wobbly windows" etc. How do I turn these things on ?

    I'm ok at shell programming but will need simple advice when it comes to linux administration stuff.

    The spec for the PC is:
    • Gigabyte EP35
    • Intel Core 2 Duo E8400
    • Saphire Radeon HD4850
    • SATA HD
    • Bog standard DVD optical drive


    Cheers

    Mike

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Make sure you have GLX enabled.
    Code:
    glxinfo |grep direct
    Then open systemsettings from the command line, not as root. Click on Desktop>Enable Desktop Effects
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Jul 2009
    Posts
    11
    From the Konsole it returned the following:
    direct rendering: Yes

    I tried typing opensystem at the Konsole

    But got the warning "Compositing is not supported on your system.
    Required X extensions (XComposite and XDamage) are not available"

    when trying to configure your computer > hardware > configure graphics > compiz & xgl
    I also had the warning "no package named x11-server-xgl "

    Not sure how to include this. The graphics card is quite flash and should be able to handle any of this stuff.

    Does any of the above help ?

    I'm getting very good now at building a Madriva OS on a PC - this is the 5th time I've done it and I can get it down to 20mins now! Sadly the last little bit of turning on the XGL Compiz stuff is eluding me

    Mike

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Look in your package manager to see if you can locate x11-server-xgl and install it.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    42
    First of all, nobody uses XGL for compiz anymore. Everyone uses AIGLX.

    ATI has horrible linux support. The free ATI driver for xorg often cannot support 'Composite' required by AIGLX & compiz. You might solve this by installing the alternative 'non-free' driver fglrx.

    Looking at your error, it might be your software sources are not yet updated.
    configure your computer > software management > configure media sources...

    You can find out if it's possible to install fglrx like this:
    configure your computer > hardware > configure graphics > setup graphical server > click graphics card > click ok to accept the default. At this point, if a non-free alternative driver exists, it will prompt if you want to use it. Once you say yes, it will download & install it. After which just reboot & you now should be able to enable compiz with aiglx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •