Find the answer to your Linux question:
Results 1 to 5 of 5
Hi there. I think this question has been asked about ten thousand times, but I could never find a half-descent answer to it. The question is: IS THERE ANY WAY ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    14

    DWL-G510 D-Link


    Hi there.

    I think this question has been asked about ten thousand times, but I could never find a half-descent answer to it.

    The question is: IS THERE ANY WAY TO GET DWL-G510 D-Link WIRELESS ETHERNET ADAPTER TO WORK? (sorry for being so loud, but I am veeeery frustrated by my inability to make it work by myself )

    Does anyone have D-Link g510 wireless adapter running on mandrake?

    If so, could you please tell me how did you do it!

    I have been trying to make the bloody thing work for two month now. Have to load in Win every time I need e-net. Tried DriverLoader as well as ndiswrapper 7, 8 and 9 with no luck at all. None of them sees my hardware. The Harddrake2 (i'm on Mandrake 10.1) identifies the card as Marvell W9500 < (not sure, have to reboot to verify ) but has no module for it. So, if not too much trouble, would you please help?

    Best regards

    it-s

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Check this out:

    http://www.linuxquestions.org/questi...hreadid=214888

    Maybe it will help.
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7
    Howdy it-s, I already PMed you, but thought of something else:

    To remove ndiswrapper COMPLETELY, then you can follow the instructions here, or you can use these instructions:

    1. open a console. update the search database as root (updatedb). Then, use the
    Code:
    gnome-search-tool
    (type exactly that in a run box or console as root) to find ANY file with ndiswrapper in it. You can probably remove anything bearing the name, I don't see how that would screw up your system. If you installed ndiswrapper from an rpm, you still need to go through this process. Don't use the KDE search tool because it doesn't seem to work with mandrake 10.

    2. look in folders related to the kernel or the kernel-source, such as /etc/modules/(your kernel) and the alias folder for the kernel-source. I can't give you the exact location because I'm not at my linux computer. It shouldn't be that hard to find, regardless.
    [/code]

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    14
    Thank you asdfjkl; I'll most definitely try that. ...as soon as I get home that is ...

    If I run into trouble I'll post it here

    And jeremy1701 I have been through that post three times already, but without much luck, however thank you a lot for consideration.

  6. #5
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    14
    Ok, I have done all that you have suggested - deleted all that corresponded with ndiswrapper ( all the dirs and files) reinstalled a fresh ndiswrapper 9 and loaded WinMe drivers. Modprobe gives no result. as before I get this after issuing dmesg command:
    ....
    ndiswrapper version 0.9 loaded
    ndiswrapper: driver mrv8k51.sys added
    ndiswrapper (NdisFreeSpinLock:855): incorrect lock c3a34772
    ndiswrapper (NdisFreeSpinLock:855): incorrect lock c3a3406f
    ndiswrapper (NdisFreeSpinLock:855): incorrect lock c3a34f62
    ndiswrapper (ndis_init_one:1299): Windows driver couldn't initialize the device
    mrv8k51.sys: probe of 0000:00:09.0 failed with error -22

    Any ideas as to what could be the couse of this errors?

    Once again - thank you for your help

    it-s

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •