Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
I am running Gnome 2.26.1...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Apr 2008
    Posts
    13

    I am running Gnome 2.26.1

  2. #12
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I'm not entirely sure why it started happening, but as a workaround so you don't have to launch things from the console with dbus-launch, you can create a new session as follows.

    Open a new file:

    Code:
    gksudo /usr/share/xsessions/gnome-dbus.desktop
    Paste the following into it and save.
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=GNOME with D-BUS
    Comment=GNOME Desktop with D-BUS support
    Exec=dbus-launch --exit-with-session gnome-session
    TryExec=/usr/bin/dbus-launch
    Icon=
    Type=Application
    then
    Code:
    sudo chmod -v 644 /usr/share/xsessions/gnome-dbus.desktop
    Turn off autologin if you have it, restart your xsession, from the login screen, change the session to gnome-dbus.

  3. #13
    Just Joined!
    Join Date
    Apr 2008
    Posts
    13
    AFter executing dbus-launch, from then on, I am able to activate firefox or Epiphany by clicking on the icon! Not sure myself what happened -- my best recollection:

    1. Informed that updates were available for system
    2. checking the updates saw nothing for concern (accepted all)
    3. The rest is History

    At the very least, I can not thank you guys enough for all the help!

    Tuxconvert

  4. #14
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Glad it all worked out!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •