Find the answer to your Linux question:
Results 1 to 5 of 5
I am connected to the internet via a permanent ADSL modem. This is always logged in and doesnt require me to log in via PPoE each time. My modems configuration ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    Problem with internet settings


    I am connected to the internet via a permanent ADSL modem. This is always logged in and doesnt require me to log in via PPoE each time.
    My modems configuration page can be found at 10.1.1.1, in my control centre, network & internet > internet access settiings my first DNS server always shows 10.1.1.1
    now this works and gives me a internet connection, however alot of sites dont work,so i go to my IPS's configuaration and get theyre DNS server ip of 203.0.178.191 and i enter 10.1.1.1 as my secondary dns server.
    When i do this, everything runs sweetly, all the net works fine including chat messengers where before only msn would work, other internet access programs run fine to and fast as intended with my dsl line.

    However, sometimes i need to enter this a couple of times before it works, and everytime i do, the first dns server always reverts back to 10.1.1.1 and slows my internet conection again so i need to reenter the control panel and reconfigure everything again.
    This also happens after wards to, sometimes in 10 minutes sometimes after 10 hours, it always reverts back to 10.1.1.1.



    Is there anyway i can force
    the internet access configuration page to keep 203.0.178.191 as my first dns server?
    Or does anyone know what i can do from within my modems internal page?
    Modem is a dlink dsl-g604T (adsl router)

    Thanks for any assistance.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    dns settings are kept in /etc/resolv.conf
    change the part where it says:
    Code:
    nameserver blah blah
    to
    Code:
    nameserver  203.0.178.191
    nameserver 10.1.1.1
    -lakerdonald

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    Thanks, just looked at that code and its set the right way.

    search net.au
    nameserver 203.0.178.191
    nameserver 10.1.1.1

    # ppp temp entry

    It still decides to change whenever it likes, once it happens again ill look at the file and see if it has changed.

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    ok, its just reverted again, i open the resolv.conf file and it now says.

    nameserver 10.1.1.1


    thats all of it

  5. #5
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    wow
    that is strange. maybe you should have cron set it every hour or so?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •