Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 28 of 28
This is what I get when I check the partition setup: Disk /dev/sda: 163.9 GB, 163928604672 bytes 255 heads, 63 sectors/track, 19929 cylinders Units = cylinders of 16065 * 512 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43

    This is what I get when I check the partition setup:

    Disk /dev/sda: 163.9 GB, 163928604672 bytes
    255 heads, 63 sectors/track, 19929 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x82898289

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 4468 35889178+ 83 Linux
    /dev/sda2 4469 19929 124190482+ f W95 Ext'd (LBA)
    /dev/sda5 4469 19929 124190451 7 HPFS/NTFS
    [root@localhost chris]# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 34G 4.4G 28G 14% /

    So, is sda5 not a file system anymore.
    I cant access the partition manager in the mandriva control either, it just exits "abnormally"

  2. #22
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    /dev/sda5 is still here as listed by fdisk.
    df says it is nt mounted.

    Post the output of :

    Code:
    cat /etc/fstab
    cat /etc/mtab
    cat /proc/mounts
    ls -l /media
    And try this :

    Code:
    mkdir /media/d
    mount -t auto /dev/sda5 /media/d

  3. #23
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43
    thanks, i got desperate before and tried to mount the partition using your previous instructions, with no luck, I don't know if I did more damage.
    heres the readouts for the prompts:

    # Entry for /dev/sda1 :
    UUID=38dc99ba-b259-4fb5-b40d-5ebd87acb3b5 / ext4 relatime 1 1
    /dev/cdrom /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
    /dev/fd0 /media/floppy auto umask=0,users,iocharset=utf8,noauto,exec,flush 0 0
    # Entry for /dev/sda5 :
    UUID=8CF8F804F8F7E9FA /dev/sda5 /media/win_d ntfs unmask=000,iocharset=utf8 0 0 mount /media/win_d
    none /proc proc defaults 0 0
    [root@localhost chris]# cat /etc/mtab
    /dev/sda1 / ext4 rw,relatime 0 0
    none /proc proc rw 0 0
    none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
    gvfs-fuse-daemon /home/chris/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=chris 0 0
    [root@localhost chris]# cat /proc/mounts
    rootfs / rootfs rw 0 0
    /dev/root / ext4 rw,relatime,barrier=1,data=ordered 0 0
    /dev /dev devtmpfs rw,relatime,size=513500k,nr_inodes=128375 0 0
    /proc /proc proc rw,relatime 0 0
    /sys /sys sysfs rw,relatime 0 0
    none /dev/pts devpts rw,relatime,mode=620 0 0
    none /dev/shm tmpfs rw,relatime 0 0
    none /proc/sys/fs/binfmt_misc binfmt_misc rw,relatime 0 0
    /proc/bus/usb /proc/bus/usb usbfs rw,relatime,devgid=43,devmode=664 0 0
    gvfs-fuse-daemon /home/chris/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=10001,group_id=10 001 0 0
    [root@localhost chris]# ls -l/media
    ls: invalid option -- '/'
    Try `ls --help' for more information.
    [root@localhost chris]# ls --l/media
    ls: unrecognized option '--l/media'
    Try `ls --help' for more information.

    tried
    [root@localhost chris]# mkdir /media/d
    [root@localhost chris]# mount -t auto /dev/sda5 /media/d
    [root@localhost chris]#

    One thing its changed is the volume is now located at /media/d but doesn't seem to contain anything. Dolphin says it cannot enter the file.

    the full line in etc/mtab is now:

    /dev/sda5 /media/d ntfs rw 0 0

  4. $spacer_open
    $spacer_close
  5. #24
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    UUID=8CF8F804F8F7E9FA /dev/sda5 /media/win_d ntfs unmask=000,iocharset=utf8 0 0 mount /media/win_d
    none /proc proc defaults 0 0
    That is an incorrect entry for /dev/sda5.

    Follow instructions carefully. Open /etc/fstab file in vim again and delete UUID line.

    Contents of /etc/fstab file should look like this
    Code:
    # Entry for /dev/sda1 :
    UUID=38dc99ba-b259-4fb5-b40d-5ebd87acb3b5 / ext4 relatime 1 1
    
    /dev/cdrom /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
    
    /dev/fd0 /media/floppy auto umask=0,users,iocharset=utf8,noauto,exec,flush 0 0
    
    # Entry for /dev/sda5 :
    /dev/sda5  /media/win_d  ntfs-3g defaults,umask=0  0   0
    
    none /proc proc defaults 0 0
    Save file and reboot machine Or execute mount -a command.
    Double check contents of /etc/fstab file. It must look like as I have posted above.
    NTFS partition will be available in /media/win_d folder.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #25
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    You did a typo error

    ls -l/media : WRONG
    ls -l /media


    The only way to lose data through a whole partition is to format again or recreate the partition. I doesn't appear that you have done either of these.

    Follow the instruction of Devis's Casper and post the output again, after having completed his instructions, of :

    Code:
    cat /etc/fstab
    cat /etc/mtab
    cat /proc/mounts
    df -h
    ls -l /media
    ls -l /media/win_d

  7. #26
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43
    thank you both again, seems to be sorted and I've tested it with a couple of reboots. The only thing that changes after I've saved is the end of the line:
    "umask=0 0 0" becomes "umask=000 0 0"
    Is there any relevance to the amount of zeros? I used mcedit instead of vim, possibly this makes a difference?
    Nmset - I've attached the read outs from the commands, please tell me if there is anything strange about my system.
    Attached Files Attached Files

  8. #27
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    The only thing that changes after I've saved is the end of the line:
    "umask=0 0 0" becomes "umask=000 0 0"
    Both are correct and 0000 or 0 doesn't make any difference.
    vim and mcedit are both very good editors and our goal was to edit /etc/fstab file only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #28
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    Your data is not lost. Now jump to a strore and get yourself a big USB stick or external hard drive. You have to backup important data if you want to continue playing with any OS.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •