Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I installed Mandrake 10.1 Community. Everything went fine and it is working. I then tried to configure network using DrakConf. When trying to add a new network interface, it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    Mdk 10.1 Community network card installation problem


    Hello,

    I installed Mandrake 10.1 Community. Everything went fine and it is working.

    I then tried to configure network using DrakConf. When trying to add a new network interface, it suggests me only 2 options:

    - usb device
    - manual selection of a driver

    First one is a little weird. It seems to be for a point-to-point connection.

    So I choosed second option. I know that this card needs 8139too driver (this card was on another box with Fedora Core 2 before and worked fine). I select this one.

    Next screen is to select automatic or manual configuration or driver options. Whatever I choose, I have a small dialog box (it closes immediately, so I can't read it) and I am back to first screen (the one with USB option)!

    I tried some manual configuration. I added this line to /etc/modprobe.conf

    Code:
    alias eth0 8139too
    Then I loaded the driver:

    modprobe 8139too

    I created ifcfg-eth0 in network-scripts (with same options as on FC2 box).
    And then I tried to bring interface up with:

    ifup eth0

    I got an error message:

    interface eth0 not found

    Does anybody have an idea of what I can do for this? Is there any bug with drakconnect? And did I miss something for manual configuration?

    Thanks a lot for any help.

    PS: I do not have Internet access on the Mandrake box.

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Sound to me like the card isn't even being detected. What kind of card is it (vendor, model, etc...)? Is the card listed in HardDrake? Is it pcmcia?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    The card is a RealTek 8139 generic one. It is plugged onto PCI bus and I tried to use different ports.

    But when doing an lspci, it appear with 8119 id. I tried to modify pcitable file to tell him that 8139too driver should be used for this kind of card, but it changed nothing (except the fact that lspcidrake tells no more it is an unknow device).

    If I look in Mandrake configuration program, in Hardware section (I thing it is HardDrake), I can see this card being recognized as an Ethernet one but with unknown driver.

    Maybe there is a hardware problem with this card (making it returning bad identifier). I will try to put it back in the other box and see what happens.

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    I swapped this card with the one in my FC2 box. And everything works perfect now

    The card with the special ID is correclty detected by Fedora (I have a recent kernel version on it, that could be the reason). And the one that Mandrake is using, returns the correct identifier.

    Maybe I will do more investigations when I will have Internet acces at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •