Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 35
I'm having 2 major problems with mandriva 2010: 1. Flash player is very slow and jerky, especially when in full screen mode. 2.My music players are very slow too. Both ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43

    mandriva performance problems


    I'm having 2 major problems with mandriva 2010:
    1. Flash player is very slow and jerky, especially when in full screen mode.
    2.My music players are very slow too. Both Amarok and Banshee take deathly amounts of time to start up and then proceed to move at snails pace when I try to skip tracks or do anything other than listen, this applies to Banshee especially which goes blank screen very often.

    Sorry for the double question, I figured they may be related, maybe my desktop is clogged with too much info? I've tried turning off some of the apparantly unnecessary services in the system tray + I turned the powersaving to perfomance, but I can't tell if either made any difference. Any other tips for improving performance generally.
    I can't find any solutions to the flash problem on google. I've read about problems with Banshee's slowness but I like its layout structure, any suggestions for a similar but better music player?

    Thanks for any help.

  2. #2
    Just Joined! dannn's Avatar
    Join Date
    Oct 2009
    Posts
    29
    I am a newbie. However, did you mount your RAM and swap file correctly when you installed it? That's all I can think. I could be wrong...

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Can you post your system specs? How much RAM? What speed is the CPU? This could more than likely be caused by not having the proper graphics driver installed, can you post the output of these commands please (as root or use sudo)?
    Code:
    lspci |grep -i vga
    Code:
    cat /etc/X11/xorg.conf |grep -i driver
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    And also :

    Code:
    uname -a
    top #the first 5 lines

  6. #5
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43
    Thanks all. I figured its probably the graphics driver but when I go to set up an X server in 'Set up the graphical display' it looks like the driver is set to the right series: Nvidia Geforce fx. Checking in the terminal shows the driver as "nv", I seem to remember from another forum that this might be the inferior Nvidia driver. If so, how do I change it?
    Mike - vga doesn't seem to exist on my system, "No such file or directory". Not sure what that means.

    Nmset, good to hear from you again, my computer is:
    Linux localhost 2.6.31.6-desktop-1mnb #1 SMP Tue Dec 8 16:20:45 EST 2009 i686 AMD Athlon(tm) XP 2600+ GNU/Linux

    and "top" shows:
    top - 20:02:06 up 43 min, 3 users, load average: 0.50, 0.45, 0.38
    Tasks: 115 total, 3 running, 112 sleeping, 0 stopped, 0 zombie
    Cpu(s): 25.4%us, 3.9%sy, 0.0%ni, 68.8%id, 1.8%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 1033280k total, 939176k used, 94104k free, 33252k buffers
    Swap: 0k total, 0k used, 0k free, 543380k cached

  7. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Checking in the terminal shows the driver as "nv"
    Yes, the nv driver is pretty limited and poor. I believe it is Nvidia's attempt at an open source driver.

    You have two other options, the proprietary Nvidia driver, or the open source nouveau driver. If you need/want 3D acceleration so you can use a compositing window manager like Compiz or Kwin's fancy effects, you need the proprietary driver at this point. (Eventually nouveua will support hardware acceleration.)

    I'm don't know exactly how to go about getting the nvidia driver in Mandriva, but there should be an option to install somewhere in the Control Center.

  8. #7
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    Usually, Mandriva tools for X setup readily offers to install the Nvidia proprietary driver, or perhaps you are not using the Powerpack release.

    Your PC should not have much performance issues, I'm still using an Athlon XP 3 Gz smoothly.
    The top output doesn't show a choking machine.

    If you want to install the Nvidia proprietary driver, you'll have to install the kernel sources first :

    urpmi kernel-source

    and choose the one tagged 2.6.31.6-desktop-1mnb.

    Next grab the relevant driver from nvidia.com

    Backup your xorg.conf file.

    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.turphy

    As root, switch to runlevel 3, set the executable bit on the Nvidia driver package and run it.


    init 3
    chmod +x <path_to_nvidia_driver>
    <path_to_nvidia_driver>


    If someting goes wrong, restore your xorg.conf and init 5 or reboot.

    If successful, the new driver will be called nvidia and you'll have to update your xorg.conf replacing nv by nvidia.

  9. #8
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by Turphy View Post
    Mike - vga doesn't seem to exist on my system, "No such file or directory". Not sure what that means.

    Issue that command as root, or use sudo, whichever your system is setup for...the problem is not that you don't have vga..........the problem is that I'm not sure of the correct path is Mandriva,,it might be /usr/sbin/lspci.
    You can find it with this command.
    Code:
    whereis lspci
    Code:
    lspci: /usr/sbin/lspci /usr/share/man/man8/lspci.8.bz2
    I've highlighted the path on my system, yours may be the same. So wherever it says it is,,,issue the command with the path or just use su - or sudo.

    Quote Originally Posted by nmset View Post
    If successful, the new driver will be called nvidia and you'll have to update your xorg.conf replacing nv by nvidia.
    The official driver should update xorg.conf for you, if you tell the installer to do so.
    Last edited by MikeTbob; 01-27-2010 at 12:29 AM. Reason: Typos
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #9
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43
    The card is nVidia Corporation NV34 [GeForce FX 5200 Ultra] (rev a1).
    I think I've found the driver I need but I'm having trouble configuring the kernel sources. I've found alot of info on the installing of the drivers such as - http://www.linuxforums.org/articles/...drivers_50.htm
    and I've been using this page - Preparing your Mandriva kernel source . I followed the instructions for using makefile to set the Extraversion name, but to no avail. This is the kernal situation as it stands now:
    [root@localhost chris]# rpm -q kernel source
    package kernel is not installed
    package source is not installed
    [root@localhost chris]# rpm -qa | grep kernel
    kernel-source-2.6.31.5-1mnb-1-1mnb2
    kernel-firmware-20090604-4mnb2
    kernel-firmware-extra-20090723-1mnb2
    kernel-source-latest-2.6.31.6-1mnb2
    nvidia-current-kernel-2.6.31.6-desktop-1mnb-185.18.36-4mdv2010.0
    nvidia-current-kernel-desktop-latest-185.18.36-1.20091209.4mdv2010.0
    kernel-desktop-2.6.31.5-1mnb-1-1mnb2
    broadcom-wl-kernel-2.6.31.6-desktop-1mnb-5.10.91.9-2mdv2010.0
    libkplatokernel6-2.0.82-4mdv2010.0
    broadcom-wl-kernel-desktop-latest-5.10.91.9-1.20091209.2mdv2010.0
    kernel-vserver-source-2.6.22.19-1mdv-1-3mdv2009.0
    kernel-desktop-latest-2.6.31.6-1mnb2
    kernel-source-2.6.31.6-1mnb-1-1mnb2
    kernel-desktop-2.6.31.6-1mnb-1-1mnb2
    [root@localhost chris]# uname -r
    2.6.31.6-desktop-1mnb

    I've attached a copy of the Nvidia installer log. Can you make anything of this?
    Attached Files Attached Files

  11. #10
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    That error message is saying you don't have the kernel sources installed, but I see that you do have them......I'm not sure what the problem is there. You also have the nvidia modules installed.....are they loaded? Use this command as root to find out
    Code:
    lsmod |grep -i nvidia
    If you do not see something like
    nvidia 8863686 38
    Then use the modprobe command to load it.
    Code:
    modprobe nvidia
    If you get no error from the above command then you should be able to login to the desktop.
    Can you post the entire /etc/X11/xorg.conf file?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •