Find the answer to your Linux question:
Results 1 to 5 of 5
Hello all. About a week in to a fresh install of Mandrake 10.0, I realized that I hadn't partitioned my disk correctly, and so my root partition was REALLY small. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    6

    Kde cant find home folder, or start services.


    Hello all.
    About a week in to a fresh install of Mandrake 10.0, I realized that I hadn't partitioned my disk correctly, and so my root partition was REALLY small. So booted into Knoppix 3.4 to repartition using QTparted. I deactivated my partition, committed it, and it wouldnt let me resize or reactivate the partition. So, I rebooted into Knoppix and reactivated the partition. I then rebooted into Mandrake, clicked my account, entered the password, and KDE began to start up, except I had errors.

    The first one was:

    Will not save configuration.

    Configuration file "//.kde/share/config/ksplachrc" not writable
    Configuration file "//.kde/share/config/kdeglobals" not writable

    Please contact your system administrator

    Then this message:

    There was an error setting up inter-process communications for KDE. The massage returned by the system was:

    Could not read network connection list.
    //.DCOPserver_evilpc.chn.comcast.net_0

    Please check that the 'dcopserver' program is running!

    Then I see the KDE splash screen, jammed up at "setting up inter process communication" 0%

    Then this message:
    The following installation problem was detected while trying to start KDE:

    No write access to $HOME directory (/).

    KDE is unable to start

    Finally, I click OK, and I am returned to the login screen.

    Iv'e tried searching the forums, iv'e tried other window managers, iv'e tried repeatedly activating and reactivating my partitions with QTparted in Knoppix, ive tried resetting the CMOS, and nothing has worked.

    I can look at the files via the terminal in Knoppix, and the worst part is, my tiny windows partition still works.

    Any help will be GREATLY appriciated,

    //Pisces

    Spex:
    Mandrake 10.0
    One 160GB SATA harddrive (in legacy ATA mode)

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28
    hi,
    the same problem was with me,i can't start the kde with user account and similar messages,i find the problem was with permission of home directory that was just for root,icheck your home permision.

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    5
    Looks like you will have to try chmod(0666) for all thew files in your hard disk. Try entering to failsafe mode(the one included in the Mandrake Linux graphic login screen, NOT in the single user, text-mode booting screen) and then try to reset permissions. I can't guarantee it will work, but since it says you cant write, well, who knows.
    Good luck!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    6
    Thanx for the replies,

    Shams, what you said makes sense, because Knoppix locks me out of the home directory in my mandrake partition.

    But how do i set the permissions to my home file?
    chmod 0666 /home/alex?

    ------And if that dosn't work-------

    how am i to get into a terminal from a graphic login when KDE wont start and the home file cant be found? From the terminal in Knoppix perhaps?
    Also, how do i set permissions for everey file on my disk?
    chmod 0666 / maybe?
    or chmod 0666 /dev/hda1 ?

    I'll try em anyway as best i can and let you know how it works.

    Thanx SOOOOOOOO much for your help
    //Pisces

  6. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28
    try to login as root if not possible when there is login screen press ctrl+alt+f6 you will get the console login enter as root and can do what do you want ,other way boot with bootdisk or knoppix,change the runlevel of /etc/inittab from 5 to 3 you can do with:
    $mcedit /etc/inittab
    save and exit then reboot without bootdisk,you will have a console login.then try
    chmod -R +0666 /home
    then you can start your x (kde) with:
    $startx
    i advise if u can have another user account with the gnome desktop if there is problem with kde u can login with gnome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •