Find the answer to your Linux question:
Results 1 to 9 of 9
I have a dual boot linux/windows box. Fat32 and linux partition on HD1 and full linux partition on HD2. I cannot transfer files into the /mnt/windows folder across the partition ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    Windows mount permissions - noob


    I have a dual boot linux/windows box. Fat32 and linux partition on HD1 and full linux partition on HD2.

    I cannot transfer files into the /mnt/windows folder across the partition on HD1 nor can I alter the permissions.

    I've tried varios file transfer programs to no avail I'm assuming because I have no write access and can't seem to change this becuase the windows partition is not active at the same time as the linux - any suggestions?

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    because of the flaws in FAT32, there are *no* file permissions on those filesystems... (further evidence that winblows is horribly and irreversibly broken) in order to be able to read/write a FAT32 partition, you *have* to be the user that mounted it... therefore, your fstab entry should look like this:
    Code:
    /dev/hda1 /mnt/windows auto noauto,user,rw 0 0
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Greece
    Posts
    187
    You have to edit your fstab.Go where there is the line of your hard disk and then edit it as root like that (mine):
    /dev/sda2 /mnt/windows/xp2 vfat gid=xxx,defaults,umask=0002 0 0
    Create a group and its gid put it in xxx then edit your user account and make sure that your account belongs in the group you just created.That with umask 0002 which means that all have read only access in this partition make sure that only root and you have write acces on it.Hope it helps

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    paulmedic,
    that won't work.. once again, FAT32/NTFS DO NOT SUPPORT UMASKS OR FILE PERMISSIONS IN ANY WAY.
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  6. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    Ok.. I had to read up on fstab but it seems to make sense now... my original line was:

    /dev/hda1 /mnt/windows ntfs umask=0,nls=iso8859-1,ro 0 0

    And changing it to --

    # /dev/hda1 /mnt/windows ntfs umask=0,nls=iso8859-1,ro 0 0
    /dev/hda1 /mnt/windows ntfs gid=501,defaults,umask=0002 0 0

    Should do the trick?

  7. #6
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    linux barely supports writing to NTFS.. and i say again FAT32 AND NTFS DO NOT SUPPORT UNIX UMASKS/FILE PERMISSIONS PERIOD.

    so you should *always* mount NTFS as read-only and any partitions you want to share between the two should be FAT32 with the fstab line i gave you.

    you then have to manually mount the FAT32 partition whenever you want to use it in linux because only the person that mounted it can read/write to FAT32
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  8. #7
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    I'm still new with command line, what is the purpose of "auto" after /dev/hda1?

    since the fstab is in fields that made it appear our of order (like I said... noob)

  9. #8
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    the 'auto' with the space on either side (after the mount point) is to tell mount to try to automatically determine the filesystem type...

    on the subject of umask:
    okay, so i was a jackass.. the umask= option for mount/fstab actually does work on winblows partitions.. but it's still not a good idea to write to an NTFS partition from linux...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  10. #9
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by lordnothing
    the 'auto' with the space on either side (after the mount point) is to tell mount to try to automatically determine the filesystem type...
    And (fyi) 'auto' in the 4th column (the options list - comma delimited) means that the partition will be mounted on boot.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •