Find the answer to your Linux question:
Results 1 to 4 of 4
The weather was good yesterday. There were a few clouds in the sky. I had my Firefox running with adblock and my favorite theme. My wireless card is faultless using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Houston
    Posts
    3

    Mozilla, Firefox and Sound


    The weather was good yesterday. There were a few clouds in the sky. I had my Firefox running with adblock and my favorite theme. My wireless card is faultless using ndiswrapper. Ok, the T-bird RPM that I loaded wasn't installing themes, but what ever. I had 10.1 DL on and it was working.

    then my friend offered me the Official version on DVD. I jumped for the commercial drivers. I did a clean install and was pleased... until... I tried to load Firefox.

    I loaded it using the same RPM and it hangs and then disappeared. I found another RPM and it did the same thing. I went to an earlier version and it OPENED after installation. But after I closed and tried to reopen it hung again. So I got the Tar and installed. Same thing. So I went to the source disk and installed Mozilla Suite. Same thing.

    I woke up this morning thinking it was the Official Version. So I clean installed the DL version and tried Firefox again. Now Firefox doesn't work with this version. I finally got a T-bird .8 to work just fine.

    I am writing this email in Root mode because that is the only way to get Mozilla or Firefox to work everytime.

    Also, for the first few sessions my sound starts up fine. Then every startx it is muted and everything is turned off. I have never turned off my sound.

    Please please help. What is going on with my firefox?

    "The sky was black and bruised and we had months of heavy rains" - T. Waits

    mW

  2. #2
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    I don't understand your problems with firefox. Here's how I installed it. Download "firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz"

    Code:
    $ su root
    <password>
    # cd /usr/local/src
    # mkdir tmp
    # cd tmp
    # tar -xzvf /path/to/firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz .
    # cd firefox-installer
    # ./firefox-installer
    <choose directory to install as /usr/local/src/mozilla-firefox-1.0PR
    <quit firefox if it opens after the install>
    # exit
    $
    Now as a normal user, if you type "/usr/local/src/mozilla-firefox-1.0PR/firefox" it will start firefox. Just make a shortcut that uses that path.

    For your sound issue, do you use alsa? Use alsactl to set and save your sound settings.
    --monkey

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Houston
    Posts
    3
    yeah, I did that. I decided to make another go at it and did a clean install again with the Official. Now, everything works.

    I think that the previous version was ghosting on the partition. When I was in setup I formatted the partition twice and that seemed to do the trick.

    Thanks for your help

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    It sounds as though you didn't format the /home partition the first time. For future reference, if FF or Moz don't work for one user, but do for another, it's much easier to simply delete the .mozilla directory then to re-install the whole system.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •