Find the answer to your Linux question:
Results 1 to 2 of 2
I recently built a computer and installed Mandriva 2010.1. It has the AMD Phenom II X2, MSI motherboard with ATI embedded graphics (no graphics card), and an older Hitachi hard ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    1

    S2ram, pm-suspend don't work


    I recently built a computer and installed Mandriva 2010.1. It has the AMD Phenom II X2, MSI motherboard with ATI embedded graphics (no graphics card), and an older Hitachi hard drive. The bios is set to S3 with no wake options enabled (like USB or ethernet).
    I have tried Mandriva One, Free, and Fedora 13. Every time I suspend to ram, the screen blanks, then turns back on, showing the lock screen if that is enabled or the desktop, with internet reconnecting.
    I installed Windows 7 and Standby did not work until I installed the ATI catalyst driver for my graphics, then it worked perfectly.
    I discovered Mandriva uses pm-suspend, running it from the terminal does not produce any messages, even with --verbose. I installed s2ram, and it gives me this output (my machine is of course not on the whitelist):
    # s2ram -f
    Switching from vt8 to vt1
    fbcon fb0 state 1
    s2ram_do: No such file or directory
    fbcon fb0 state 0
    switching back to vt8
    #

    Does anyone know what this s2ram_do is?
    Any suggestions are greatly appreciated!

  2. #2
    Just Joined!
    Join Date
    Dec 2004
    Posts
    6

    swap?

    I wonder if "No such file or directory" means that you have no swap:

    ubuntuforums.org/showthread.php?t=1144999

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •