Find the answer to your Linux question:
Results 1 to 5 of 5
So, trying to get things set up on a new Mandriva install. Have been trying to set up dual monitors, but haven't been able to get the driver installed. Anyway, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! ChaoticTheory's Avatar
    Join Date
    Sep 2010
    Posts
    17

    Red face I think I broke it (No GUI)


    So, trying to get things set up on a new Mandriva install. Have been trying to set up dual monitors, but haven't been able to get the driver installed. Anyway, that is a different thread.

    Currently I changed a setting to enable 3D and now all I get is the text interface, after I get Fatal Error: No monitor found (or something like that).

    I tried running XFdrake, and making changes there, but every time I click test the screen goes rainbow with a "Are these settings correct" dialog. I have tried both Yes and No but both cause me to lose all display and have to reboot.

    I did try xorg.conf file, but didn't see any think that looked like it pertained to 3D.

    Any help is much appreciated. I could just reinstall, but I am trying to learn, and a big step in learning is figuring out what you did wrong

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    How/where did you change the settings "to enable 3D"?
    Post your /etc/X11/xorg.conf please, let's have a look. Which video card do you have?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined! ChaoticTheory's Avatar
    Join Date
    Sep 2010
    Posts
    17
    It was under computer management>displays>Options (or something along, going from memory )

    Here is what xorg.conf shows:
    Code:
    Section "ServerFlags"
      Option "DontZap" "False" 
      AllowMouseOpenFail
    EndSection
    
    Section "Module"
      Load "v4l"
    EndSection
    
    Section "Monitor"
      Identifier "monitor1"
      VendorName "Plug'n Play"
      ModelName "FHX2300"
      HorizSync 31-83
      VertRefresh 56-76
    
      ModeLine "1920x1080" 148.5 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    
      ModeLine "768x576    50.00 768 832 846 100   576 590 595 630
    
      ModeLine "768x576"   63.07 768 800 690 1024   576 578 590 616
    EndSection
    
    Section "Device"
      Identifier "device1"
      BoardName "ATI Radeon HD 2000 And later (radeonhd/fglrx)"
      Driver "radeonhd"
      Option "DPMS"
    EndSection
    
    Section "Screen"
      Identifier "screen1"
      Device "device1"
      Monitor "monitor1"
    EndSection
    
    Section "ServerLayout"
      Identifier "layout1"
      Screen "screen1"
    EndSection
    I left out the comments (denoted by # in the file) since I typed this manually. If you need those let me know.

    GPU is a Sapphire Radeon HD5770.

    Thanks!

  4. #4
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    If you only need to get a graphical session, you may create and use a new xorg.conf file this way :
    Code:
    #as root
    init 3
    #Create a new xorg.conf ->  /root/xorg.conf.new
    Xorg -configure
    mv /etc/X11/xorg.conf /etc/X11/old.xorg.conf
    mv /root/xorg.conf.new /etc/X11/xorg.conf
    init 5
    XFdrake should have resolved the problem completely however.
    0 + 1 = 1 != 2 <> 3 != 4 ...
    Until the camel can pass though the eye of the needle.

  5. #5
    Just Joined! ChaoticTheory's Avatar
    Join Date
    Sep 2010
    Posts
    17
    Fixed it! I found a file called xorg.conf.old and looked at it, it had the Driver set to "ati", made that change and it loaded fine.

    I also got the driver to install (had to chmod -x file), but could still use help. I posted updated info in my Dual Monitor thread.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •