Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I am trying to install Dummynet in Mandriva 2010. When I tried to build, it gave the following error: ************************************************** ************************************* # make echo target is all target is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    17

    Post [SOLVED] Installing Dummynet in Mandriva Linux!


    Hello,

    I am trying to install Dummynet in Mandriva 2010. When I tried to build, it gave the following error:

    ************************************************** *************************************
    # make
    echo target is all
    target is all
    (cd ipfw && make all )
    make[1]: Entering directory `/root/dummynet/ipfw3/ipfw'
    Makefile:9: Building userland ipfw for Linux
    echo "Done build for Linux VER "
    Done build for Linux VER
    make[1]: Leaving directory `/root/dummynet/ipfw3/ipfw'
    (cd dummynet2 && make all )
    make[1]: Entering directory `/root/dummynet/ipfw3/dummynet2'
    Makefile:30: including dummynet/Makefile
    Makefile:63: "---- Building dummynet kernel module for Version 2.6"
    Makefile:257: "---- Building Version 2.6 2.6 in /lib/modules/`uname -r`/build"
    grep: /lib/modules/2.6.31.5-desktop-1mnb/build/include/linux/version.h: No such file or directory
    Makefile:264: "---- Perhaps you miss a (cd /lib/modules/`uname -r`/build; make oldconfig; make prepare; make scripts)"
    /bin/sh: line 0: [: -le: unary operator expected
    make -C /lib/modules/`uname -r`/build V=1 M=`pwd` modules
    make: Entering an unknown directory
    make: *** /lib/modules/2.6.31.5-desktop-1mnb/build: No such file or directory. Stop.
    make: Leaving an unknown directory
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/root/dummynet/ipfw3/dummynet2'
    make: *** [all] Error 2
    #
    ************************************************** *************************************

    Then I found that some packages are required to be installed. One of the required package libncurses5 is already installed. But it seems it also requires the linux-headers since it is required to build as he previous make was searching for path
    /lib/modules/`uname -r`/build.

    I would like to know how to solve this problem. I tried to find the required linux-headers through rpmdrake (visual tool) but was not able to locate.
    I need to install from a CD since there is no internet connection in the machine.

    Any help is highly appreciated!
    Thanks!

  2. #2
    Just Joined!
    Join Date
    Jun 2009
    Posts
    42
    You need the kernel-devel package. In your case it should be kernel-desktop-devel-2.6.31.5-1mnb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •