Find the answer to your Linux question:
Results 1 to 5 of 5
Recently I upgraded computer to Asus A7N8X-E MB with Athlone XP 3000+ and had to get a new video card, a ATI Radeon 9520 with 128 Mb ddr. I kept ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3

    Changing motherboard and CPU and video card - Can't boot Lux


    Recently I upgraded computer to Asus A7N8X-E MB with Athlone XP 3000+ and had to get a new video card, a ATI Radeon 9520 with 128 Mb ddr.

    I kept the old case and power supply (300Watt, which might be causing trouble since I am forced to run the CPU at half the published performance).

    I kept the old hard drive, 120 Gb, which contains 2 partitions with Win98se and 2 partitions for Mandrake Linux 10.0 + a swap partition and a partiton for common use across all systems.

    I had no trouble with the 2 windows se partitions. However, I can't boot Linux. It stops with the message that it couldn't find the inittab file and asks for a power level. I can't get past this point and have never seen it before. I tried a re-install (upgrade) from the original CD's and it appears to work.

    Any help is definitel;y appreciated. Please..

    PS: I can be emailed directly at zswameejee@shenwisdom.com please remove the 'z' from the beginning of the email address.

    Thanks.

  2. #2
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    127
    Um, you are sort of confusing. You're saying you did an upgrade and it worked. So what is the problem if it worked?

    I'd sort of expect you to have to reinstall, if you change the cpu/motherboard that usually upsets OS's. WIndows XP sure doesn't like it, and linux isn't going to be a huge fan either.

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3
    The upgrade sort of worked, as long as I set the Bios to run at half the designed speed, i.e. 1.33 Ghz instead og the 2.1 Ghz that I expected. That is one problem and quite separate to the Linux boot problem.

    I mis-typed the OS names. On the hard drive that wasn't upgraded are 3 operating systems: 2 separate copies of windows 98 second edition (one is a backup in case of a real mess, the other I use all the time. The third operating system is Mandrake Linux 10.0 community, kept up to date with all the fixes I could find. By the way, I can no longer find those fixes on the internet, which is a seaprate subject from this posting.

    My Linux problem is that Linux worked pretty well until I upgraded the hardware (MB, CPU and video card). I fully expected to have to install new drives and so on. However, all attempts to boot Linux causes the message about the inittab file being missing and the run level question. I can't understand how the inittab file got deleted. Anyway, I did an upgrade from the ISO cd and it said all was well. But I still get the same error messages. Shouldn't I at least be able to boot into a terminal command line screen? After all, the upgrade screens all looked correct and I seem to remember that the new hardware was found during the upgrade. Would that alone cause a new inittab file to be created?

    Thanks for your interest and input:

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Oct 2004
    Location
    B'ham Alabama
    Posts
    240
    The major upgrade you did was the motherboard. The CPU and video card won’t affect booting. The motherboard is a foundation or building block. You would be lucky if you could boot to any thing at all. Generally speaking if you change that much you changed the architecture. If you made a boot disk put it in and you’re ok. If you do not have one search for answers if you like but you will more than likely need to reinstall.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    3

    inittab missing etc.

    well, I guess I got lucky. I remembered that I had copied the partitions to another hard drive some months ago as a back up and with great care, deleting this weird Linux partition, I replaced it with the months old copy.

    I used the boot floppy and the CD1 that I originally installed from (ISO download) and suddenly everything works again. The onmly thing which needs looking at is the sound driver, since I have sound in KDE but not Gnome!

    So the missing inittab has been replaced and all is well. Still don't know how it goy deleted or corrupted. I can tell you one thing though: Every time I have tried to use the included paetition manager in Linux, it has royally screwed up the partition table on the disk. Since I have 3 systems on the HDD, I am thoroughly pissed off at that. I even tried using a bootable CD full of Linux goodies, including a partition manager and that wrecked thr partition table as well! For some reason, Partition Magic refuses to help complaining about various errors like not being able to identify her drive letters and so it is useless. However, an oldcopy of System Commander along with Ranish has saved my bacon. Otherwise all would have been lost.

    I guess I am lucky since all the drivers have been installed from the CD1 upgrade, even the Radeon video card.

    Now, if I can onlt get this cpu up to its offical speed...... (

    Thanks for all your input.

    swamiji

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •