Hello everyone,

I've been banging my head against the wall with this one. I've had a few folks on IRC trying to help me, but they've now ran out of ideas! So I figured I'd try here.

Here's the quick version: I just upgraded (from 2007) to 2010.2 on a brand new PC. All was well at first, then no more sound at all after a reboot. Except, for some reason, at startup & shutdown. Anything else doesn't work at all (music, videos, etc -- I've tried with xmms, xine, mplayer and youtube to no avail). OTOH, logging in to a root session DOES work. Which is somewhat reassuring, I suppose. I've also tried creating a brand new user, but that did not do the trick either. Only root seems to work as expected.

And now, for the gritty details on how this all started...

I reinstalled my whole system last Thursday. Everything was working fine for about two days. Then, at one point, I was prompted to use --auto-orphans. The concept was new to me (coming from Mandriva 2007) and seemed intriguing & interesting. So I tried it out... NEVER AGAIN!

Shortly afterward, I got a popup stating that some sound drivers were no longer required, should they be removed or no? Before clicking anything, I played some music and it was fine, so I figured what the hey, might as well clean house a bit, so I clicked yes. Shortly after THAT I had to reboot to test some other stuff, and once I was back in KDE... I had no more sound!!! It has been like this for days now.

I have since had that popup message about unused sound drivers 3 times more:
- the second time, I clicked "no";
- the third time, I noticed there was a third button I hadn't noticed about configuring the devices or somesuch. I clicked on it and, lo and behold, it took me to the KDE > Computer Administration > Multimedia panel (I'd been there earlier, trying to fix the problem) where I now could see a lot more devices than earlier... and one of them new ones (hw:0,0) actually worked when I tested it (all others didn't and never did before). So I was all excited, tossed it at the top of the list, saved the settings, rebooted KDE and... still no sound! And testing hw:0,0 again in kcontrol no longer worked!
- and finally, the fourth time I got that annoying popup, I checked the "don't show me this window anymore" box before hitting the NO button. So it hasn't bugged me anymore since.

OK. Now here's some info on my system, that might be useful:

- Mandriva 2010.2 (fresh install, from last Thursday)
- KDE 4.4.3
- Soundcard: built into my motherboard, a Gigabyte 870A-UD3
(the card is reported as a Realtek ALC892 by numerous reliable sources)
- Kernel: 2.6.36.2-server-2mnb
- Both the alsa & sound services are running
- Also, alsa-lib & alsa-utils are both installed

A few commands I've tried (my comments, where appropriate, are in boldface parenthesis, underneath each output):

# lspcidrake -v | fgrep AUDIO
(brings up nothing at all)

# grep sound-slot /etc/modprobe.conf
alias sound-slot-0 snd_hda_intel model=ALC892
alias sound-slot-1 snd_hda_intel model=ALC892
(I initially had just "alias sound-slot-0 snd_hda_intel" and I've also tried with model=6stack, none of it worked)

# lsmod | grep snd
snd_hda_codec_nvhdmi 14155 4
snd_hda_codec_realtek 234934 1
snd_hda_intel 23357 7
snd_hda_codec 92717 3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda _intel
snd_bt87x 9826 1
snd_hwdep 5648 1 snd_hda_codec
snd_seq_dummy 1382 0
snd_seq_oss 30277 0
snd_seq_midi_event 6047 1 snd_seq_oss
snd_seq 50859 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6096 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 41451 0
snd_pcm 78622 6 snd_hda_intel,snd_hda_codec,snd_bt87x,snd_pcm_oss
snd_timer 18881 3 snd_seq,snd_pcm
snd_mixer_oss 14102 2 snd_pcm_oss
snd 58735 25 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda _intel,snd_hda_codec,snd_bt87x,snd_hwdep,snd_seq_d ummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_os s,snd_pcm,snd_timer,snd_mixer_oss
soundcore 6428 2 snd
snd_page_alloc 7312 3 snd_hda_intel,snd_bt87x,snd_pcm

# chkconfig --list sound
sound 0:off 1:off 2:on 3:on 4:on 5:on 6:off 7:off

# chkconfig --list alsa
alsa 0:off 1:off 2:on 3:on 4:on 5:on 6:off 7:off

# aumix -q
vol 69, 69
line 77, 77
mic 0, 0
pcm2 61, 61
igain 61, 61
dig1 0, 0, P

# fuser -v /dev/dsp
(brings up nothing at all)

# lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/corwin/.gvfs
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
knotify4 2329 corwin mem CHR 116,9 8950 /dev/snd/pcmC0D0p
knotify4 2329 corwin 13u CHR 116,9 0t0 8950 /dev/snd/pcmC0D0p
kmix 2544 corwin 12u CHR 116,12 0t0 8956 /dev/snd/controlC0
kmix 2544 corwin 14u CHR 116,6 0t0 8905 /dev/snd/controlC1
kmix 2544 corwin 15u CHR 116,21 0t0 9328 /dev/snd/controlC2
gkrellm 2635 corwin 12u CHR 14,0 0t0 8957 /dev/mixer
VirtualBo 5518 corwin mem CHR 116,10 8951 /dev/snd/pcmC0D0c
VirtualBo 5518 corwin 34r CHR 116,2 0t0 8867 /dev/snd/timer
VirtualBo 5518 corwin 35u CHR 116,10 0t0 8951 /dev/snd/pcmC0D0c
VirtualBo 5518 corwin 36u CHR 116,12 0t0 8956 /dev/snd/controlC0

That's all I can think of for now. Let me know if you need anything else...

Thanks in advance for your help!!!