Find the answer to your Linux question:
Results 1 to 4 of 4
I have a freshly installed Mandrake 10.1 Community. My video card is a GeForce FX. I am trying to install an nvidia driver called NVIDIA-Linux-x86-1.0-629-pkg1.run. I was previously booting into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    NVIDIA question


    I have a freshly installed Mandrake 10.1 Community.
    My video card is a GeForce FX.
    I am trying to install an nvidia driver called NVIDIA-Linux-x86-1.0-629-pkg1.run.

    I was previously booting into X using the 'nv' driver. This functioned fine.

    I booted into failsafe mode, typed "telinit 3", and installed the driver.
    I changed 'driver = "nv"' to 'driver = "nvidia"' in /etc/X11/xorg.conf file and verified that the modules section contained 'Load "glx"', and did not contaiin 'Load "dri"' or 'Load "GLcore"'.
    I opened /etc/X11/XF86Config and saw that that file already contained 'driver = "nvidia"' (possibly from my editting of xorg.conf?).

    I tried to boot into X, and failed.
    I opened /var/log/Xorg.9.log and observed that it contained the line

    "(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

    This message appeared to correspond exactly to one of the questions in the NVIDIA faq, with the answer being that the NVIDIA kernel was most likely built using different headers than the kernel I am using (to my understanding).

    I have tried running the installer with the following commands, all with the same results as given above.

    sh NV*
    sh NV* --kernel-source-path = [/usr/src/linux]
    sh NV* --kernel-source-path = [/usr/src/linux-2.6.8.1-10mdk]

    I can still boot into X if I change the driver back to 'nv'.

    ------
    Possibly relevant command prompt responses
    ------

    # urpmi kernel-source
    Everything already installed.

    # urpmi binutils
    Everything already installed.

    # rpm -qa | grep kernel
    kernel-2.5.8.1.10mdk-1-1mdk
    kernel-source-2.6-2.6.8.1-10mdk

    --------

    This is my first installation of linux, so I tried to err on the side of verbosity with this post. I have a sneaking suspicion that I'm missing something very obvious. =) Thank you for your help!

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    you need to modprobe the nvidia kernel driver like so:
    Code:
    su -  //only if you're not root already
    modprobe nvidia
    exit
    startx
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2
    Thank you!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1

    NVIDIA question

    Yea! Thanks lordnothing! Modprobe fixed my problem, too..... sorta



    The NVidia driver starts but the video is corrupted. The screen does not refresh. Video gets overlaid on old pixels. I did do a recompile of the kernel to remove the rivafb driver before I tried to install. Since the NVidia installer actually ran without complaining about rivafb, I can only assume it was the right thing to do. What else am I missing?

    My system: Mandrake 10.1, Dell Precision 410, 256MB RAM, Pii 450MHz, Riva TNT2 w/32MB RAM, 1024x768x24, Dell M780 monitor.

    Right now I am running using the "nv" driver.

    my xorg.conf has this:

    ===

    Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Dell M780"
    HorizSync 30-85
    VertRefresh 50-160

    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync
    -vsync

    # Dell D800 and few Inspiron (16/10) 1280x800
    ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

    # Dell D800 and few Inspiron (16/10) 1680x1050
    ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

    # Dell D800 and few Inspiron (16/10) 1920x1200
    ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSy
    nc

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
    EndSection

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corp."
    BoardName "RIVA TNT2"
    Driver "nv"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
    Depth 8
    Virtual 1024 768
    EndSubsection

    Subsection "Display"
    Depth 15
    Virtual 1024 768
    EndSubsection

    Subsection "Display"
    Depth 16
    Virtual 1024 768
    EndSubsection

    Subsection "Display"
    Depth 24
    Virtual 1024 768
    EndSubsection
    EndSection

    ===



    My /var/log/Xorg.0.log has this line in it:

    ===
    (EE) Failed to initialize GLX extension (NVIDIA X driver not found)
    ===

    That is while running using the "nv" driver.

    Also, why are there LCD definitions in there? I am not on a laptop. Are they safe to remove?

    My apologies if this is too much information. I have been trying for a week to install NVidia drivers. Between the zillion or so kernel recompiles (dang dependencies!) and the NVidia driver itself, I am at my wit's end.


    Happy New Year,

    Markov

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •