Find the answer to your Linux question:
Results 1 to 10 of 10
Thanks to alll who helped get my soundcard up. I think I am down to the tweaking phase. I have Mandrakelunux 10.1 with KDE4.2. The sound card is an ISA ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    68

    smaller sound card issues


    Thanks to alll who helped get my soundcard up. I think I am down to the tweaking phase. I have Mandrakelunux 10.1 with KDE4.2. The sound card is an ISA ESS1869. I had to run "alsaconf" in order to get the card to work. Here is the card setup: E/A port= 0x220, IRQ=5, DMA=1, MPU-EA= 0x330. I know this because of when it was configured. As to where to find it now, I have no idea.
    The issue is that it plays the test sound in KDE Sound System file. Computer .wav files and the system bell do not test or play. Music CDs do not play. Also, "test Midi player" under KDE Sound System does not do anything. When I look at the hardware tab under KDE sound system, it is on auto detect, and no selection of a midi device is possible. Any ideas?

  2. #2
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    Re: smaller sound card issues

    have you tried experimenting with some of those other hardware options from the dropdown to see if they make any difference?

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Run kmixer (or whatever KDE's mixer is called) and make sure your PCM volumes are turned up. Play with the other volumes, as well, like CD, etc.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Sarumont might be on to something there. Make sure to check your gain level. On both of my MDK boxes, the defualt setting was inaudibly low.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    68
    The volumes are all the way up. I am not able to hear CDs or system sounds. I also tried to go with the other hardware options, open threaded, auto detect, etc.... when I hit apply the system does a lot of loud crackling since the volume is up so high, but then it stops and there is no sound. I did get an error once, "artd" when I was switching the different sound hardware devices. Nothing else though.

  7. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Tom, If I remember correctly, you said you also had sndconfig?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  8. #7
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Have you tried restarting KDE? If you got an artsd error, that could be your problem, too. artsd is KDE's sound daemon, which takes sounds from multiple programs and runs them through one stream to the soundcard.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  9. #8
    Just Joined!
    Join Date
    Nov 2004
    Posts
    68
    Yes, both sndconfig and alsaconf downloaded with Mandrakelinux 10.1. I can not get the sndconfig to work though. I just can't find the correct combination of settings for the ESS 1869 card. It attempted to let me try to install other cards at one time, but that was in a blind attempt at trying to get it to work. As far as KDE, when mentioned to restart it, do you mean to simply restart the computer or is there another method of starting just KDE? With the sound daemon, I have seen that in the KDE Sound System hardware tab. Is that the hardware I should set it too? Or, should I set it to auto detect or Linux Sound System.... ? I appreciate the information. I am new and feel like I have exhasusted my hunches with this. At the moment I am reading up on some midi information and have not tried to use alsoconf or sndconfig. I am trying to keep it clean until we find a resolution or something to try. Thanks again.

  10. #9
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You can restart KDE by hitting CTRL+ALT+BKSPACE.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  11. #10
    Just Joined!
    Join Date
    Nov 2004
    Posts
    68
    the system restarted, but the sound is the same. No midi is listed in the hardware unerder KDE 3.2 Sound System. Should I install Pmidi or Kmid or something similar?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •