Find the answer to your Linux question:
Results 1 to 5 of 5
Was installing win xp and mandrake on a Dell laptop inspiron 8500 2.2ghz, 512 mb, 40gb of hhd. Win is properly installed, mandrake got installed as well but whenever i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    1

    Is mandrake not compatible with certain laptop?


    Was installing win xp and mandrake on a Dell laptop inspiron 8500
    2.2ghz, 512 mb, 40gb of hhd.
    Win is properly installed, mandrake got installed as well but whenever i choose to load mandrake, my laptop makes an acute sound (unbearable) it's just impossible to wait and see if mandrake is going to continue loading.

    Anyone who have an idea on it?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    try reinstalling mandrake

  3. #3
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    I've had Several Linux flavours on my i8500. I'm also a big Mandrake user so I've had 9.0,9.1,9.2,10.0, and now 10.1 installed. I've had troubles but next to none with 10.1CE.

    Use Mandrake 10.1 and you'll have no bother at all. In fact most trouble I ever had was with nVidia drivers, DVD crap and a USB drive that was allergic to mandrake. However like I said all of my troubles were fixed in this release and it runs like a beast even with Ksmoothdock and a Karamba theme.

  4. #4
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Actually it just occured to me....
    I had this trouble before. Your sound card is an i845 chipset, but earlier drivers in Mandrake are terrible, as it picks up your headphones as primary output and shorts the speakers.


    Guess what....not in 10.1.


    Try to boot all the way (Stick in headphones to shut it up) then use the i810 audio drivers. This will make it work okay but they may fail to load in low power situations like battery/speedstep.

  5. #5
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Here I go ressurecting an old thread again - I had similar problems to this old one when installing LE2005. Because the driver was giving me some trouble when trying to switch it I dug a bit deeper. If you find on a laptop (particularly on an 845 chipset) that the headphones sockets work but the main speakers don't then you need to edit /etc/asound.state.
    first run
    Code:
    alsactl store
    There should be a config message containing the string "External Amplifier" or "External Amplifier Power Down" :
    Code:
    control.38 {
    comment.access 'read write'
    comment.type BOOLEAN
    iface MIXER
    name 'External Amplifier Power Down'
    value false
    }
    Change the value false part to value true.

    after saving run
    Code:
    alsactl restore
    and you should be good to go - but if you're using KDE note that there may be need to turn on KDE sound from it's control centre.


    Just sharing the wealth....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •