Just installed the DVD edition of Mandriva 2011 64 bit on my Sony VPCEB26.

It has an ATI Mobility HD 5650 graphics card.

Tried to install fglrx-kernel and driver from the repo, but it gave an error saying it is for Kernel 2.6.37 and Kernel 2.6.37 is not available.

So, downloaded the latest 'run' script from Ati's website, version number 11.8.

When I tried to create the Mandriva rpm with that one, this is the error I got

Generating package: Mandriva/2011.0
mv: cannot stat `/tmp/amd.DChRn1/RPMS/*/*.rpm': No such file or directory
Created package: /home/sree/Downloads/*.rpm
Removing temporary directory: fglrx-install.3HszNh


I thought that was odd, since I had it working fine on the 2011 beta.

Then I went back to the old ati run file, 11.7, and tried to build the rpm package and everything went fine. I got five rpms, including debug pack, made.

I installed all five of them by right clicking on them.

Now, the funny thing is, I get scores of around 1,500 frames per second on fgl-glxgears benchmark, while I get only 750 on the same machine on my Centos 6 and Debian Wheezy installations. (Even less on my OpenSuse 11.4).

The differences are carried over when the gears window is maximized too. Overall, the system feels cooler and 'better'. CPU usage is less than 1% most of the time (it used to be around 5-9% in Deb, Centos, OSuse etc.)

Any idea about why this huge performance boost? Could it be that I chose to install the devel and debug packages along with the driver, module etc?

There is also another funny thing. I use the native 64 bit adobe flashplayer plugin (extract, copy paste to .mozilla folder etc.)

However, its hardware acceleration does not seem to be working in Debian, Centos, OpenSuse and Mandriva when I used KDE.

The only thing it seems to be working is Centos Gnome. In fact, I have both Gnome and KDE installed on my Centos 6 partition. When I log in to Gnome, I can play flash videos full screen without any issue (even full HD 1080p). However, on the same installation, when I log in to KDE, the full screen mode is a slide-show. Any idea why acceleration fails in KDE?

It is a problem for Mandriva, as you can imagine.

It might be possible that hardware acceleration on the 32-bit wrapped version of flashplayer may work on KDE. I have not tested as I don't want lots of 32-bit stuff on my machine.

The Centos flashplayer (that works in Gnome) is 11 beta 64 bit.