Hello,

I am trying to install a wireless card with a realtek 8180 chipset. I use Mandrake 9.2 distribution. The kernel version is 2.4.22-10, with gcc 3.3.1

I have followed a few methods I found on forums and here I am:
I have downloaded the driver from realtek.com (pre-compiled for kernels 2.4.20 and gcc 3xx). Of course, he pre-compiled driver does not work.
When I try to compile it, I get errors, the 2 main ones seem to be:

1.
/usr/include/asm/processor.h:55: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)

2. Multiple errors in /usr/include/linux/version.h, with a message that I put in a P.S. None of the paths given in this message correspond to anything in my distribution. I guess it is related to the following line in the Makefile

INCLUDEPATH=-I /usr/src/linux-$(KERNELRELEASE)/include/

This path does not exist either in my distrib. I could not find the equivalent paths.

Can anyone help me? I am a newbie and I am lost!


P.S.:
#error "================================================= ======"
#error "You should not include /usr/include/{linux,asm}/ header"
#error "files directly for the compilation of kernel modules."
#error ""
#error "glibc now uses kernel header files from a well-defined"
#error "working kernel version (as recommended by Linus Torvalds)"
#error "These files are glibc internal and may not match the"
#error "currently running kernel. They should only be"
#error "included via other system header files - user space"
#error "programs should not directly include <linux/*.h> or"
#error "<asm/*.h> as well."
#error ""
#error "To build kernel modules please do the following:"
#error ""
#error " o Have the kernel sources installed"
#error ""
#error " o Make sure that the symbolic link"
#error " /lib/modules/`uname -r`/build exists and points to"
#error " the matching kernel source directory"
#error ""
#error " o Now copy /boot/vmlinuz.version.h to"
#error " /lib/modules/`uname -r`/build/include/linux/version.h"
#error ""
#error " o When compiling, make sure to use the following"
#error " compiler option to use the correct include files:"
#error ""
#error " -I/lib/modules/`uname -r`/build/include"
#error ""
#error " instead of"
#error ""
#error " -I/usr/include/linux"
#error ""
#error " Please adjust the Makefile accordingly."
#error "================================================= ============