Find the answer to your Linux question:
Results 1 to 8 of 8
I can't seem to login to GUI as root user.. It works fine with my normal user, but i get an error message when I try to start x as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! feddersen's Avatar
    Join Date
    Dec 2004
    Location
    Norway
    Posts
    82

    Can't login to GUI as root


    I can't seem to login to GUI as root user..
    It works fine with my normal user, but i get an error message when I try to start x as root...
    When I use the GUI login the system automaticaly logs in as the normal user. without asking for a passw. or user.

    Is there a way to fix the login so that i can choose to login as root?

    alt:

    Is there a way to go into superuser mode in GUI?
    su command doesn't help much since it only works in the konsoll...

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    You should NEVER log in as root, as this can cause a shed load of damage (mostly by acident).

    You should be able to do all the things you need in the terminal, what is it you want to do as root?

    What errors do you get when you try startx as root?

    I'm not familiar with Mandrake, but look arout do see if there is a SuperUser mode version of Konqurer (or similar) lying around.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    you can have it not do the automatic login in the control center, iirc

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    root login is disabled somewhere in mandrake control centre
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  6. #5
    Just Joined!
    Join Date
    Dec 2004
    Location
    Finland
    Posts
    6
    At first, I'm assuming you're using KDE. But using other WM:s doesn't make much difference.

    From KDE, you can change the login options from: click the "K-panel", and then navigate to "System","Configurate", "KDE" and then search for something like "Login options" (not sure how they are written, I'm using the Finnish version of my system =)). From there you'll find a page (from the upper corner) that says "Users". Now you can make your SU login to become visible.

    But, as said, you should try to learn to control your system through the terminal...it's a LOT more effective way of dealing things than being a SU in graphical mode. =)

  7. #6
    Just Joined! feddersen's Avatar
    Join Date
    Dec 2004
    Location
    Norway
    Posts
    82
    The problem is that my current user is only able to write to the Home dir. And I need to install programs, websites and so on... I'm also using Gnome, because the kDe desktop doesn't work... think some of the packages was damaged during download..

  8. #7
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    If you want to install programs do them as 'su' in the terminal and you can copy webpages with 'cp' command to were you want them in your / folder;

    hope this helps;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  9. #8
    Just Joined! feddersen's Avatar
    Join Date
    Dec 2004
    Location
    Norway
    Posts
    82
    well thanks for all help, I ended up installing mandrake again and now it all works well

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •