Find the answer to your Linux question:
Results 1 to 3 of 3
I just installed mdk10.1 and the printer configuration did not autodetect my hp psc 2110 printer. I have been running mdk10.0 for over a year using the printer with no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    Mandrake 10.1 printer autodetect failure


    I just installed mdk10.1 and the printer configuration did not autodetect my hp psc 2110 printer. I have been running mdk10.0 for over a year using the printer with no problems. Also I tried an install of fc3 and the printer worked fine with that distribution. When I turn the printer on after boot, I get a "Disabling IRQ #21" message from the system log. Suggestions please.

  2. #2
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    A friend found a post on the "disabling IRQ" message which provided the fix. We disabled the USB 2.0 support in the BIOS and the printer was installed and works fine. It may be a kernel problem with 2.6.8 . FC3 (kernel 2.6.9) seems to work OK without the BIOS mod.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    1

    In some cases ACPI must be enabled

    I found this thread but it didn't help ... then found another that mentioned that USB support in newer kernels is broken unless ACPI support is enabled. Once I'd enabled it both in the Configure Your Computer tool (Mandrake Control Center) using the Boot Loader config, and also enabled it in the BIOS then USB worked for me and USB printer setup was easy and crash-free.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •